Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Standard What version of dgi.go do you use.

Discussion in 'Phantom 3 Help' started by badpilot1, Feb 15, 2017.

  1. badpilot1

    Joined:
    Jan 8, 2017
    Messages:
    5
    Likes Received:
    0
    Location:
    Minnesota
    I am really new here and have been reading some of the posts on the DJI.GO app I live in Minnesota and have not flown my phantom 3 standard yet I'm getting a bit worried about flying it 1 post says I got a new update and my drone flew away. To the point what version of the go app is going to make my drone safe to fly and I don't have to worry about it getting a mind of it's own and flying off to god knows were.
     
  2. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    27,888
    Likes Received:
    8,674
    Location:
    Harrisburg, PA (US)
    You'll be fine as long as you're using the current version of DJI GO.
     
  3. Numone

    Joined:
    Jan 10, 2016
    Messages:
    2,475
    Likes Received:
    816
    Location:
    Surrey, England
    It'll tell you to update the app if an update exists. I'm on iOS , I have the latest "everything" and the 3A flies perfectly.
     
  4. badpilot1

    Joined:
    Jan 8, 2017
    Messages:
    5
    Likes Received:
    0
    Location:
    Minnesota
    Thanks for the quick reply I am using android 6.0 if I have any problems maybe it is time to get an ipad.
     
  5. dirkclod

    dirkclod Moderator
    Staff Member

    Joined:
    May 9, 2014
    Messages:
    12,838
    Likes Received:
    6,874
    Location:
    Amory Mississippi
    I use both go apps and am up to date on both and have no issues . Am on the latest firmwares as well .
    And I use a mini .
     
  6. ChiefStealth

    Joined:
    Dec 9, 2016
    Messages:
    196
    Likes Received:
    70
    Location:
    Graham, Wa. USA
    Rather than say what version to use, I'll say what version to not use. Do not use DJI Go v3.1.2 for Android. Serious problems with that version.
    Edit: But, come to think of it, even if you did install v3.1.2 you would soon be forced to upgrade to v3.1.3 anyway.
     
    #6 ChiefStealth, Feb 15, 2017
    Last edited: Feb 16, 2017
  7. kirk2579

    Joined:
    Jan 13, 2015
    Messages:
    1,579
    Likes Received:
    326
    Location:
    Girard. ohio
    wait for issues before you start solving them
    GO 3.1.3 is latest and is the fix for the issue you are concerned about
     
  8. badpilot1

    Joined:
    Jan 8, 2017
    Messages:
    5
    Likes Received:
    0
    Location:
    Minnesota
    I got the latest 3.1.3 I think kirk2579 said the right thing, I will see what happens when I fly, fingers crossed everything will be ok Thanks for all the reply's I'm just a little jumpy about flying the first time I just got to quit over thinking every thing.
     
Loading...
Similar Threads - version dgi Forum Date
P2 vision + version 3 follow me feature. Phantom 2 Vision Help Yesterday at 3:25 PM
P4 Firmware Is it possible to get an old version of Go to go with old firmware? Firmware Yesterday at 1:19 AM
P3 Firmware New version Firmware Friday at 10:48 PM
P3 Firmware What are the latest firmware versions? Firmware Jan 15, 2018
Downgrade firmware V01.03.0509 with RC firmware version? Firmware Jan 2, 2018