Standard Weak RC Signal 25 feet off the ground

Joined
Jan 30, 2016
Messages
3
Reaction score
0
Age
42
I'm new and cannot figure out why i can't fly my phantom 3 standard more than 25 feet high without my RC signal failing? Is there something in settings I didn't do correctly? Thanks!
 
Joined
Nov 14, 2015
Messages
493
Reaction score
112
Age
64
Location
Wisconsin
Antennae aimed properly?
 
Joined
Nov 14, 2015
Messages
493
Reaction score
112
Age
64
Location
Wisconsin
Location, any local interference? Cell phone or Bluetooth?
 
Joined
Jan 30, 2016
Messages
3
Reaction score
0
Age
42
hmm, good question? i use my iPhone 6 and i don't think i turn my bluetooth off. I will check that...hopefully that's all it is. Thanks fordruid. I will let you know if that's the problem.
 
Joined
Sep 16, 2015
Messages
252
Reaction score
50
Age
65
hmm, good question? i use my iPhone 6 and i don't think i turn my bluetooth off. I will check that...hopefully that's all it is. Thanks fordruid. I will let you know if that's the problem.
It's recommended to turn off the WiFi one your tablet or smartphone when flying.
 

msinger

Approved Vendor
Joined
Oct 30, 2014
Messages
31,684
Reaction score
10,661
Location
Harrisburg, PA (US)
Website
PhantomHelp.com
It's recommended to turn off the WiFi one your tablet or smartphone when flying.
This is not possible since the mobile device needs to use Wi-Fi to connect to the remote controller. However, it would be okay to enable airplane mode and then turn Wi-Fi on.
 

msinger

Approved Vendor
Joined
Oct 30, 2014
Messages
31,684
Reaction score
10,661
Location
Harrisburg, PA (US)
Website
PhantomHelp.com
Is there something in settings I didn't do correctly?
There are no settings in DJI GO that would cause this to occur. Here are some things to try:

1) Make sure you're pointing the remote controller antenna like this:

P3-Antenna-Position-Single.jpg



2) Try flying in a different location. This will rule out a potential interference issue.

3) Check that the antenna is not damaged on your remote controller. If you think this might be the case, you could open your remote controller to inspect the antenna wire more closely.
 
Joined
Sep 16, 2015
Messages
252
Reaction score
50
Age
65
This is not possible since the mobile device needs to use Wi-Fi to connect to the remote controller. However, it would be okay to enable airplane mode and then turn Wi-Fi on.
On the Phantom P3A
This is not possible since the mobile device needs to use Wi-Fi to connect to the remote controller. However, it would be okay to enable airplane mode and then turn Wi-Fi on.
 

msinger

Approved Vendor
Joined
Oct 30, 2014
Messages
31,684
Reaction score
10,661
Location
Harrisburg, PA (US)
Website
PhantomHelp.com

Members online

Forum statistics

Threads
142,061
Messages
1,460,390
Members
103,843
Latest member
Scrumpys