Vision Cannot Connect to Phantom

Joined
Sep 8, 2014
Messages
51
Reaction score
0
This must be my day of everything going wrong. Replaced controller batteries and charged remote (2nd time today), but had a hard time finding the wi-fi link. Previously today, the iPhone would find it promptly and I would select it and then go to Vision. Earlier today, communication between controller and the plane was suffering for some reason, but today, after replacing/charging the batteries, my controller finally could start the motors. Previously today I had to do an advanced IMU calibration (why? I don't know). But now the Vision Camera linkage is failing ("Cannot connect to Phantom"). For a bit of time, a couple of hours ago, I could see the image from the camera -- now, I'm getting the cannot connect msg persistently.

Does this mean that I've lost the binding? What could cause this problem?

Thanks, for reading
-Tim
 
Joined
Sep 8, 2014
Messages
51
Reaction score
0
In addition to my comment about Chinese connector quality, I would advise everyone to be careful in not inserting the craft's battery with a hard and rapid push. On one of my copters, this action caused the back of the battery to slam up against the grey ribbon cables at the back of the battery chamber which extended out somewhat from the back. I don't have evidence of pulling on connectors, but I surmised that it might happen.
 
Joined
May 16, 2014
Messages
3,530
Reaction score
625
Location
Sydney Australia
Stab in the dark.,,

There are 3 sets of flat grey cable connectors that come from the phantom to the gimbal.
1 is a clip in and the other 2 are plug ins.

Get some tweezers...
If your telemetry (battery/sats/SD card) and tilt doesn't work, inspect the clip in.
If your wifi has issues, then pull the other 2 cables out and plug back in and plug back in tightly.

Send me a beer if this has resolved your issues.
 

New Threads

Forum statistics

Threads
136,126
Messages
1,407,849
Members
99,050
Latest member
UFOcommander