Video feed issues on P4

Joined
Jan 6, 2016
Messages
56
Reaction score
21
Location
Orange County, CA
Hi guys - I was wondering how many other people are having the same issue with their P4 in terms of video feed. I just recently purchased the P4 a few months ago and seem to be having video feed issues almost every time I fly it. I'll start flying it for a minute or so and get it up in the air then it'll start having the black/green screen overlay while freezing at the same time. Then it goes back to normal then sometimes goes back to the black/green screen. I'm not sure what's causes it, whether it's a actual P4 internal problem, frequency problem, or iPad 3 mini problem. It's really inhibiting me from doing paid projects for real estate. I start flying it over some property and the screen goes haywire causes me to not get the correct shot right because the whole screen froze. I feel like it's the bird itself but then again I've read it could be the iPad can't keep up with the processing power. I'd think the iPad mini 3 would be ok on processing power. Don't remember if I used my iPhone 7 yet for comparison. It's really driving me nuts, especially on work projects!! Help! Thanks in advance.
 
Joined
May 29, 2014
Messages
807
Reaction score
194
Do you have your downlink on automatic or a specific channel? Go to the HD section on the GO app and see what is happening before you fly and when you get tin the air. You may find manually selecting a channel with less interference works better than auto select... and sometimes it's the other way around.
 

msinger

Approved Vendor
Joined
Oct 30, 2014
Messages
31,280
Reaction score
10,435
Location
Harrisburg, PA (US)
Don't remember if I used my iPhone 7 yet for comparison.
Try running your iPad Mini with these settings. If that does not help, then try your iPhone 7 to see if you can reproduce this issue with a different device.
 

New Threads

Members online

Forum statistics

Threads
139,576
Messages
1,439,896
Members
101,354
Latest member
SellhouseMediaLV