Advanced Startup issues on my p3 advanced

Joined
Dec 16, 2017
Messages
4
Reaction score
0
Age
22
okay, so basically today was my first time flying my p3 advanced. After some flying i landed on an uneven surface, resulting in it tipping over, and 2 props being stuck in mud. I cut the engine and set it up to fly again. However, upon startup, only 2 engines fired, and only for a fraction of a second (these were the engines that didnt get stuck in the mud). i then brought it back home to recharge the battery etc. After the battereis were recharged i notice that it needed a firmware update so i proceeded to download that. I then removed the props (because the drone was indoors) and turned it back on. It showed red lights on 2 of the legs and then fast, blinking yellow ones on the other two. On my phone (galaxy s7) it showed that there was no controller signal and a video connection could not be made to the drone.
 

Oso

Premium Pilot
Joined
May 19, 2015
Messages
4,495
Reaction score
3,345
Location
Western US
okay, so basically today was my first time flying my p3 advanced. After some flying i landed on an uneven surface, resulting in it tipping over, and 2 props being stuck in mud. I cut the engine and set it up to fly again. However, upon startup, only 2 engines fired, and only for a fraction of a second (these were the engines that didnt get stuck in the mud). i then brought it back home to recharge the battery etc. After the battereis were recharged i notice that it needed a firmware update so i proceeded to download that. I then removed the props (because the drone was indoors) and turned it back on. It showed red lights on 2 of the legs and then fast, blinking yellow ones on the other two. On my phone (galaxy s7) it showed that there was no controller signal and a video connection could not be made to the drone.
Have you done the relinking as mentioned in the release notes for 1.11.20?

Click here for some background and other very important information about the flight distance restrictions with 1.11.20.

Also, welcome to the forum.

If you are interested, click here for some tips that I often share with new P3A/P3P owners. One of the tips is about not using a CSC command to stop the motors after you land. I suspect that was the cause of your tip over.

Cheers!
 
Last edited:
Joined
Dec 16, 2017
Messages
4
Reaction score
0
Age
22
Have you done the relinking as mentioned in the release notes for 1.11.20?

Click here for some background and other very important information about the flight distance restrictions with 1.11.20.

Also, welcome to the forum.

If you are interested, click here for some tips that I often share with new P3A/P3P owners. One of the tips is about not using a CSC command to stop the motors after you land. I suspect that was the cause of your tip over.

Cheers!
ty for your help i will try this out tomorrow :)
 

New Threads

Forum statistics

Threads
137,421
Messages
1,420,412
Members
99,804
Latest member
oliviamails