Resolved - Help Phantom 3 Advanced - Constant Beeping and Flashing Red / Green on Card Slot

Joined
Apr 8, 2015
Messages
113
Reaction score
22
Age
41
Location
Wisconsin
I just tried to upgrade my firmware on the Phantom 3 Advanced, and I might of turned it off before it was done. I assumed it was done since the lights had stop flashing or doing anything. The Phantom 3 is now beeping at me constantly and the lights are flashing red / green. What should I do? Thanks in Advance. The weather is gorgeous in Wisconsin and I really wanted to get out tonight.
 
Joined
Sep 24, 2014
Messages
548
Reaction score
249
You turned it off too early. The last stage lights are off and gimbal is limp.
 
Joined
Jan 29, 2015
Messages
4,851
Reaction score
2,068
Location
Salt Lake City, UT
From what I've noticed the camera flashes like this while it's updating. It should also be beeping, D, D, D, D. When it's done it will beep, DD, D. Just wait for that DD, D. Heck, just turn it on and walk away for 10 or 15 minutes.
 
Joined
Sep 14, 2015
Messages
19
Reaction score
0
Age
49
It scares me a lot. Those beeping constant beeping.... different tones faster and faster... wow

This is what I'm experiencing after a minor crash into a bush. I've searched all over the internet for solutions and have found none. I've done all of the following and still nothing. Basically it seems the p3 can not communicate with the app/controller because I can't even get the IMU to work. Here is what happened. I updated the latest firmware a few days ago and then the crash happened Saturday morning 9/12/15. The gimbal seems to be fine so far when I fire up the P3 but there are NO LIGHTS and this same constant loud long beeping that changes. I've tried reinstalling the firmware after formatting the sd card in the P3 and still that failed. I will include the txt file from that attempt in this post. Basically the last line says, "Reboot the aircraft and try to upgrade the firmware again." Well, I don't know how to reboot the aircraft any different than I have by turning it off and then on again. I mean I've let this thing run for almost an hour and still nothing. If I could get a IMU calibration option in my app then may be something would work? Any suggestions from seasoned veterans?
 

Attachments

  • P3X_FW_RESULT_AB.txt
    4.4 KB · Views: 1,599

4wd

Joined
Mar 31, 2014
Messages
2,532
Reaction score
430
Location
North York Moors
Is that text file copied directly from the SD card?
It's unusual if so with all the previous success listed.
I think you're supposed to delete the file from the card after checking it, but obviously saving them all to another place is fine.

But back to your problem.
You hit a bush and it wouldn't restart.
Why would updating the firmware fix that?
There's a few things could be damaged but trying to update firmware when it won't run won't have helped any diagnosis.

Something that can happen in a minor jolt is the mechanical movement sensor inside gets stuck.
A sharp tap to the case will often free it. It's more likely something has come adrift inside though.
There are a few plugs have been known to break loose, or a solder connection cracked off.
Getting inside the P3 is more difficult than previous versions but not impossible.
It could be worth looking for anything obviously not in place.
 
Joined
Sep 14, 2015
Messages
19
Reaction score
0
Age
49
Is that text file copied directly from the SD card?
It's unusual if so with all the previous success listed.
I think you're supposed to delete the file from the card after checking it, but obviously saving them all to another place is fine.

But back to your problem.
You hit a bush and it wouldn't restart.
Why would updating the firmware fix that?
There's a few things could be damaged but trying to update firmware when it won't run won't have helped any diagnosis.

Something that can happen in a minor jolt is the mechanical movement sensor inside gets stuck.
A sharp tap to the case will often free it. It's more likely something has come adrift inside though.
There are a few plugs have been known to break loose, or a solder connection cracked off.
Getting inside the P3 is more difficult than previous versions but not impossible.
It could be worth looking for anything obviously not in place.


Yes copied directly from the SD card. The SD card was formatted so the previous txt files were deleted. The ONLY thing on the formatted SD card was the newest firmware which already was loaded into the craft before it went down.

I never said it wouldn't turn on if that's what you mean by "restart". Never said it "won't run" either. Not sure what you mean by either of those terms. It turns on and even shows SAFE TO FLY in the app.

I don't think I'm versed enough to take this thing apart and look at it. That kind of scares me too. I will try giving it a "sharp tap" to see if I can "free it".
 

4wd

Joined
Mar 31, 2014
Messages
2,532
Reaction score
430
Location
North York Moors
No lights and constant loud beeping doesn't sound like normal start up.
It's not worth us guessing what might have gone wrong apparently after hitting the bush.
All you can do is go over it and make sure none of the cables are obviously pulled out then consider sending it for repair.
 
Joined
Sep 14, 2015
Messages
19
Reaction score
0
Age
49
No lights and constant loud beeping doesn't sound like normal start up.
It's not worth us guessing what might have gone wrong apparently after hitting the bush.
All you can do is go over it and make sure none of the cables are obviously pulled out then consider sending it for repair.


Yeah I haven't been able to get a hold of DJI support as they are always inundated with calls and they hang up on you automatically and ask you to try later. I've contacted Drone Nerds in FL and will probably send there. I haven't been able to see any cables disconnected or anything else that seems out of whack but I'm not a tech or repair guy so that's part of my issue I guess in assessing the situation.
 
Joined
Sep 20, 2015
Messages
1
Reaction score
0
Age
40
Yeah I haven't been able to get a hold of DJI support as they are always inundated with calls and they hang up on you automatically and ask you to try later. I've contacted Drone Nerds in FL and will probably send there. I haven't been able to see any cables disconnected or anything else that seems out of whack but I'm not a tech or repair guy so that's part of my issue I guess in assessing the situation.
 
Joined
Sep 14, 2015
Messages
19
Reaction score
0
Age
49

list are you having same issue getting a hold of DJI? They are harder to get a hold of than the WH!
 
Joined
Dec 25, 2015
Messages
12
Reaction score
0
Age
69
No lights and constant loud beeping doesn't sound like normal start up.
It's not worth us guessing what might have gone wrong apparently after hitting the bush.
All you can do is go over it and make sure none of the cables are obviously pulled out then consider sending it for repair.
make sure led lights are enabled in the app
 

New Threads

Members online

Forum statistics

Threads
140,084
Messages
1,444,685
Members
101,854
Latest member
Danimus