RC just blinks with 1 light, not charging

Joined
May 3, 2018
Messages
1
Reaction score
0
Age
45
Hey there
I have troubles with charging my Rc. It just blinks with one light, and doesn't start charging. Just like this:
Any suggestions?
Thx
Morten
 
Joined
Oct 31, 2014
Messages
1,964
Reaction score
333
Age
49
Location
Manchester UK
Hey there
I have troubles with charging my Rc. It just blinks with one light, and doesn't start charging. Just like this:
Any suggestions?
Thx
Morten
It’s a mainboard failure I’m afraid, the battery is full but the board sees it as empty, I’ve seen a few posts on FB groups about this issue
 
Joined
Aug 1, 2018
Messages
1
Reaction score
1
Age
51
Hey there
I have troubles with charging my Rc. It just blinks with one light, and doesn't start charging. Just like this:
Any suggestions?
Thx
Morten
don't know if you have fixed the problem but my controller did exactly the same go on youtube and look for the fault there you will get lots of videos on how to fix it you take the back off in 2 parts disconnect the internal battery for a minute or two put back together and it should work fine no cost involved mine works perfectly now
 
  • Like
Reactions: planedr
Joined
Jul 31, 2018
Messages
6
Reaction score
0
Age
51
Hi there the problem with no charge or less is the chip next to the lights on right hand side has dry solder ' so u tube how to strip down then get a heat gun or take to computer shop and ask if they can reflow it.....
It's easy do e lots of these do t panic " see attached image for the chip in question
 

Attachments

Joined
Jul 23, 2017
Messages
65
Reaction score
10
Age
43
A BIG thank you to Ashy01 for the pic of the offending area. I have had issues with mine too but after your description I went back in and put 350' c on that little sucker for 15 seconds and another 15 on the other side for good measure. I had been reflowing for 3 times previous generally all round the main board with some success but it would eventually revert back after a few week but it meant I was close to it. Funny though as I disassembled the rc their was No voltage from the battery so I bypassed the balance board by soldering to the other side of the board ....fairly quick and simple but also demonstrates there are issues in there as well. All good so far.
There maybe something at play between the balance board and this tiny ic chip.
Anyone with issues (out of warranty) I recommend balance board bypass and the ic chip reflow at above temps/time.
 

New Threads

Forum statistics

Threads
134,577
Messages
1,392,252
Members
98,101
Latest member
Airfx