Phantom Vision2+ Won't Power Up

Apr 23, 2015
Reaction score
I was having limited Wifi range, so I took out the Wifi module and changed the thermal paste. Since re-installing it, the drone won't power up. Just makes a chirping sound and then shuts off.

I bought a replacement Wifi module but no change.

The bottom LED's blink green very briefly, and a red light coming from the receiver board lights up. After the red light blinks the unit powers off.

I know a lot of times this is traced back to ESC boards, but my understanding is if the underside LED from the ESC board blinks green at start up, then the board is OK. All four of mine blink green, very briefly.

A also bought a replacement receiver board. I didn't fully install, but disconnected the leads from the old one and plugged into the new with the same result.

Any ideas? I have a trip planned to the Sierras in a couple of weeks and was hoping to get some shots of Sierra canyons before the drought takes effect this summer. I really really appreciate any and all help getting this drone working again.
Tried with another battery?
Remove the wifi module cable and power up with out it.
Did you knock out the big black capacitor near the wifi module when you were trying to remove it?
  • Like
Reactions: Sierra Aviator
if memory serves me , when I took mine off I was surprised to see 2 heavy power wires under it.

I was grateful I did not knick then while getting tape undone. maybe check that area of board under module
  • Like
Reactions: Sierra Aviator
Thanks for the replies everyone.

1) I tried disconnecting the Wifi module. I assume you mean the six strand connector at the front. No difference.

2) I tried a different battery. No difference.

3) I was real careful not to bump that electrolytic next to the Wifi module. But who knows. I tried testing the cap (and the one next to it) but am not getting a reading. I'm guessing they would need to be removed, or at least one leg, to test. I have a new central board coming, so I can try changing the board out. When I get the original board out I'll pull the cap and test it.

4) No short on the main power leads beneath the Wifi module. With the battery out the two leads have no continuity.

I did notice one thing though. According to this picture...

from this page...

...My main controller (orange box) connections weren't hooked up properly. Unfortunately I had a friend take a look at the drone, and I know he had pulled some of those connections out of the main controller. What I found was that connection that you see in that pic at the upper right (coming from the front of the central board next to the gps connector) was hooked up at the left side, below the connection that you see in that pic at the upper left. Which was installed at the middle position.

Hooking it up to the correct location (coorect according that that page anyway) now makes no difference. I'm thinking him putting this in the other spot may have fried the main controller (orange box). Does anyone know if putting this connector on the left side would do that? Could this have killed any other components?
Ok, so the EXP connector was hooked up to the ground row pins, and the LED (USB) connector was hooked up to the power row pins. Hmm, not sure what would happen with that. It was quite a bad mistake, though.

Perhaps try unplugging the X3 plug (power supply) from the Naza module, then seeing if you can power up?
  • Like
Reactions: Sierra Aviator
I've tried that already no luck.

Hm. From what you just said it sounds like the power lead was connected to ground. I prob fried something on the central board...
Since you're looking at replacement the central board anyway, I'd go ahead and try disconnecting the power leads of the ESCs one-by-one, and trying to power up after each one. If it still doesn't stay on after everything is disconnected, you'll know the problem is in the central board.
  • Like
Reactions: Sierra Aviator
Zen that's a great idea. I'm doing that tonight.

If I do need an esc or two I need to get them ordered up like now.

Hey do you know how that orange main controller box is secured to the central board? Is it sticky tape like the WiFi module?
  • Like
Reactions: Jimmykjimmy
Yes, the Naza (main controller) is stuck down with double-sided foam tape.
You can peel it up just like the wifi module. It all comes up intact if you're patient and careful.
  • Like
Reactions: Sierra Aviator
CityZen that turned out to be great advice. Last esc tested was the culprit. Central board, wifi module and main controller all good.

I don't think hooking up the X3 hurt anything, weird coincidence but I guess the esc cooked right before I pulled the wifi.

Thanks for the great help!
Glad you found your problem.

Just get a few more parts, and you'll be able to put together another Phantom :)

Members online

No members online now.

Forum statistics

Latest member