P4 plus and Litchi loading

PhantomWetSuits

Approved Vendor
Joined
Jun 3, 2017
Messages
1,001
Reaction score
466
Age
54
I did not find any great links. But this is what I did:

1) Updated the firmware of the P4P+ Remote Controller. I downloaded the latest firmware from DJI's web page DJI Phantom 4 Pro – Specs, Tutorials & Guides – DJI I unzipped the file, put it on a micro sd card, inserted the micro sd card and rebooted the controller. I now have firmware 01.04.01.00 on the controller

2) Went to DJI CrystalSky - Litchi and followed the intructions to install Amazon Appstore and subsequently Litchi from Amazon Appstore. Finally with right controller firmware this went smoothly

I also updated the firmware of the drone and the DJI Go app. I have not tested any of this yet as I just got it installed and the weather is bad here right now. But at least I got Litchi to install...
Awesome: I have two concerns , one being the lag so many people on amazon talk about and the second being that I run older firmware on the drone so this is helpful. Thank you.
 
Joined
Dec 25, 2018
Messages
6
Reaction score
4
Age
58
For what it is worth, I tried my first simple mission with Litchi and P4P+. Observations:

1) Multiple times I got "Signal lost" when the drone was on the ground a 5 meters away ?!

2) I tried to program a simple mission to take some photos at given intervals (about 15). It took one photo at the beginning and one at the end so not at all what my mission was set up to do.

3) Litchi stopped in the air after the last waypoint. I assume I have to add one extra waypoint to get to fly back to home automatically. Is this correct or or there a better way ?

These experiences do not exactly inspire confidence in the reliability of the Litchi / P4P+ combination but I will test more tomorrow. It would be great if anyone has some comments to the problems above.
 

PhantomWetSuits

Approved Vendor
Joined
Jun 3, 2017
Messages
1,001
Reaction score
466
Age
54
For what it is worth, I tried my first simple mission with Litchi and P4P+. Observations:

1) Multiple times I got "Signal lost" when the drone was on the ground a 5 meters away ?!

2) I tried to program a simple mission to take some photos at given intervals (about 15). It took one photo at the beginning and one at the end so not at all what my mission was set up to do.

3) Litchi stopped in the air after the last waypoint. I assume I have to add one extra waypoint to get to fly back to home automatically. Is this correct or or there a better way ?

These experiences do not exactly inspire confidence in the reliability of the Litchi / P4P+ combination but I will test more tomorrow. It would be great if anyone has some comments to the problems above.
I am in the middle of this Litchi School and on his very first Tutorial he talks about how to end the mission with a Hover or RTH or something else.

You can watch it for free or take the class, its pretty good and will allow me the jump start.

https://www.udemy.com/phantom-filmschool/?ranMID=39197&ranEAID=TnL5HPStwNw&ranSiteID=TnL5HPStwNw-5kUlWGlfxLzcQWjgzcsp4g&LSNPUBID=TnL5HPStwNw
 
  • Like
Reactions: anderscl
Joined
Sep 11, 2017
Messages
410
Reaction score
181
Age
57
Location
mabank TX
I am glad you got it working my version on the controller is v-0 1.0 3.0 6.00 updated July 18th 2018. In lychee you must tell it exactly what to do for every leg of its Journey. You can go to lychee on your PC in the mission Hub you login you can program the mission and see it on the Google Map you must specify at the end of the flat what you wanted to do such as land hover return home. I generally set a waypoint near the start point or where I will be standing at the time the mission ends that way is it gets near me I can watch it stop hover take control and manually land. Lychee is a good app you should have every confidence in it. The problem Lies when anyone has trouble is usually human error and they fly Beyond line-of-sight in panic and start doing crazy things.
 

PhantomWetSuits

Approved Vendor
Joined
Jun 3, 2017
Messages
1,001
Reaction score
466
Age
54
For what it is worth, I tried my first simple mission with Litchi and P4P+. Observations:

1) Multiple times I got "Signal lost" when the drone was on the ground a 5 meters away ?!

2) I tried to program a simple mission to take some photos at given intervals (about 15). It took one photo at the beginning and one at the end so not at all what my mission was set up to do.

3) Litchi stopped in the air after the last waypoint. I assume I have to add one extra waypoint to get to fly back to home automatically. Is this correct or or there a better way ?

These experiences do not exactly inspire confidence in the reliability of the Litchi / P4P+ combination but I will test more tomorrow. It would be great if anyone has some comments to the problems above.

Where are the Test did you do any ?
 
Joined
Dec 25, 2018
Messages
6
Reaction score
4
Age
58
I tested P4P+ and Litchi some more yesterday and things went well, most problems I had when I started turned out to be lack of knowledge on my part. Like having to set Straight lines in Path mode if I want photos at waypoints and adding a RTH action at the end. Th udemy.com course recommendation was an excellent idea, thanks PhantomWetSuits !
 

PhantomWetSuits

Approved Vendor
Joined
Jun 3, 2017
Messages
1,001
Reaction score
466
Age
54
I found the problem. Turns out I was not using the latest remote controller firmware 01.04.01, I was on 01.02.00.00. I tried to upgrade yesterday via DJI assistant but it must not have worked. I now updated via sd card and now I was able to install both Amazon Appstore and Litchi
Fantastic, I also want to thank you for giving me the missing piece of the puzzle to getting LITCHI installed on my Pro Plus contoller.

I am having 1 issue and that is the Battery is showing 0% on all my batteries , no updates are showing up for the battery firmware fix.

I am 1 step closer : Notice the Voltage is showing the correct values of the battery but not the Head Display, the same thing is now happening on the Pro Plus controller as well.

So any ideas keep me posted thank you.

I can still fly as it seem that it relies more on the voltage than the display.

This also may be do to the fact that i am using older firmware on the drone.

I may have to keep the app in the download and reinstall the older firmware on the controller.

Screen Shot 2018-12-27 at 12.22.05 AM.png


Screen Shot 2018-12-27 at 2.08.46 AM.png


Screen Shot 2018-12-27 at 12.21.11 AM.png
 
Last edited:
Joined
Mar 6, 2017
Messages
8
Reaction score
0
Age
70
I did not find any great links. But this is what I did:

1) Updated the firmware of the P4P+ Remote Controller. I downloaded the latest firmware from DJI's web page DJI Phantom 4 Pro – Specs, Tutorials & Guides – DJI I unzipped the file, put it on a micro sd card, inserted the micro sd card and rebooted the controller. I now have firmware 01.04.01.00 on the controller

2) Went to DJI CrystalSky - Litchi and followed the intructions to install Amazon Appstore and subsequently Litchi from Amazon Appstore. Finally with right controller firmware this went smoothly

I also updated the firmware of the drone and the DJI Go app. I have not tested any of this yet as I just got it installed and the weather is bad here right now. But at least I got Litchi to install...
I have installed the Litchi app on my P4P+ and can't quite get it to work. I can fly the drone in FPV mode with Litch although I can't get it to take off as it is supposed to. When I tap the "Take Off" button and tap "Take Off" in the pop-up screen, nothing happens. I can start the aircraft by pushing sticks to top corners and then to bottom corners. The motors will start and the aircraft flies normally. Except tapping the return to home button on the screen does nothing. I can return to home using the controller RTH button normally. Also, I can create and save waypoint flights, but when I tap the "Play" button I get the popup about the flight but when I try to fly the mission I get the voice message that the mission failed to upload. I feel that I am so close to success but I am still missing something. Has anyone solved this problem?
 
Joined
Dec 2, 2014
Messages
428
Reaction score
114
I have installed the Litchi app on my P4P+ and can't quite get it to work. I can fly the drone in FPV mode with Litch although I can't get it to take off as it is supposed to. When I tap the "Take Off" button and tap "Take Off" in the pop-up screen, nothing happens. I can start the aircraft by pushing sticks to top corners and then to bottom corners. The motors will start and the aircraft flies normally. Except tapping the return to home button on the screen does nothing. I can return to home using the controller RTH button normally. Also, I can create and save waypoint flights, but when I tap the "Play" button I get the popup about the flight but when I try to fly the mission I get the voice message that the mission failed to upload. I feel that I am so close to success but I am still missing something. Has anyone solved this problem?
One question: Are you using the USB cable and patching the USB ports on the controller?
 
Joined
Mar 6, 2017
Messages
8
Reaction score
0
Age
70
Yes I am. I just don't seem to be fully connected to the aircraft. I can take pictures and video, but I can't change camera settings.
 
Joined
Sep 11, 2017
Messages
410
Reaction score
181
Age
57
Location
mabank TX
I have had Litchi on mine since it became available through Amazon. I have never been able to get the auto take off to work. To fly a mission you want to upload next to the first person view you will tap and you should see way points tap that on the left side of the controller it will bring up the folders tap the folder that contains the missions see the mission there tap it it should pop up in the center of the screen tap the mission in the center of the screen it will highlight then tap the upload button. I am currently when the controller comes on and the aircraft is on it says go fly I go to settings an apps click on the litchi and litchi starts up I am not using cables to connect the ports on the back that is something that just started when I updated lychee last week, hope this helps you
 
Joined
Mar 6, 2017
Messages
8
Reaction score
0
Age
70
I have had Litchi on mine since it became available through Amazon. I have never been able to get the auto take off to work. To fly a mission you want to upload next to the first person view you will tap and you should see way points tap that on the left side of the controller it will bring up the folders tap the folder that contains the missions see the mission there tap it it should pop up in the center of the screen tap the mission in the center of the screen it will highlight then tap the upload button. I am currently when the controller comes on and the aircraft is on it says go fly I go to settings an apps click on the litchi and litchi starts up I am not using cables to connect the ports on the back that is something that just started when I updated lychee last week, hope this helps you
I am able to get to the point where the pop-up comes up to start uploading the mission. After a few seconds the upload never happens and the voice states "Mission failed to upload" (or something to that effect). Are you saying you can run Litchi without the USB "jumper cable" on the controller?
 
Joined
Dec 2, 2014
Messages
428
Reaction score
114
Yes I am. I just don't seem to be fully connected to the aircraft. I can take pictures and video, but I can't change camera settings.
After the last update from Amazon, I've found that having that cable plugged in affects the app, Try it without the patch cord. Only thing is you'll have to go into the app drawer and tap Litchi to start up.
 
Joined
Mar 6, 2017
Messages
8
Reaction score
0
Age
70
IT WORKS! I did not connect a jumper cord, turned on the controller, as soon as controller booted-up I clicked the gear icon at the top of the screen, tapped "All Applications", clicked on Litchi app, fired up the drone and everything works. In FPV mode the auto launch function worked, switched to Waypoints, loaded a saved mission, tapped the "play" icon and off went the aircraft on the mission. Amazing. Thanks for your help.
 
Joined
Dec 2, 2014
Messages
428
Reaction score
114
IT WORKS! I did not connect a jumper cord, turned on the controller, as soon as controller booted-up I clicked the gear icon at the top of the screen, tapped "All Applications", clicked on Litchi app, fired up the drone and everything works. In FPV mode the auto launch function worked, switched to Waypoints, loaded a saved mission, tapped the "play" icon and off went the aircraft on the mission. Amazing. Thanks for your help.
Glad for you. I had the same problem last month after updating the app after the drone sat for several months. I went through all the hoops, even resetting back to factory. I stumbled on this after I had exhausted everything else. Absolutely nothing in the Litchi release notes to tell you the cord isn't required anymore
 
Joined
Mar 6, 2017
Messages
8
Reaction score
0
Age
70
Yeah, that is strange. I had all but given up until your suggestion. So far Litchi is working flawlessly. You would think the Litchi folks would want to get the word out to P4P+ owners so they could sell more software. Thanks again.
 

New Threads

Forum statistics

Threads
134,932
Messages
1,395,926
Members
98,323
Latest member
luzack