P2V+ Remote no Power & no Lites????

Joined
Nov 28, 2015
Messages
2
Reaction score
0
Age
44
Guys and Gals.....
Im new to the site and have a question.
The last time I flew my P2V+ I accidentally left the remote on.
Today when I went to fly i noticed this and the power light was not illuminated.
I thought it must have been the batteries went dead due to being left on.
I replaced the batteries and still no power.

Has anyone ever experienced this?
Is my remote dead?

HELP PLEASE
 
Joined
Apr 10, 2014
Messages
2,276
Reaction score
1,250
Age
48
Location
Sarasota, FL. USA!
make sure you installed the batteries correctly, ( + / - )
I know sounds stupid, but I've done this before, if still no, hook to RC ASSISTANT, see if she comes to life?
Maybe reinstall firmware?

Let us know, also make sure your leads are not corroded?

J Dot
 
Joined
Nov 28, 2015
Messages
2
Reaction score
0
Age
44
I have checked the batteries and they are right.
When I open RC assistant it says I need to connect the remote and i have done so, it is not recognizing because no power.

Is there a way to reinstall firmware when the remote is not recognised?
 
Joined
Apr 10, 2014
Messages
2,276
Reaction score
1,250
Age
48
Location
Sarasota, FL. USA!
Check inside remote for anything unplugged, broken ( wires ) , or damaged! My remote turns off after a while, first starts beeping, then shuts off, if I leave it on too long! I guess it could have burnt something, but usually the fail safe takes over?
Just check every connection, if not a new remote might be in order!

Let us know?

J Dot
 
Joined
May 16, 2014
Messages
3,530
Reaction score
626
Location
Sydney Australia
You replaced with NEW batteries?
Don't go el-cheapo and pull out the TV remotes. These could be almost dead flat.
 

New Threads

Forum statistics

Threads
140,265
Messages
1,446,017
Members
102,034
Latest member
Currahee506