No image transmission signal - P3P

Joined
Mar 30, 2017
Messages
11
Reaction score
3
Location
Ireland, Dublin.
Thank you for a links and manuals, I have two "no video boards" both after crash, so I bought cheap USB to TTL FT232RL and tried to flash but every time I try I get this - check my picture last strokes "file ubl1.img is not present.... interfacing to dm36x via uart failed" can it be bad ft232rl, I have extracted files to C: root and tried few times same zip, also I found here "phantom_hack" and its the same issue. I have already ordered new other kind USB To Serial Adapter Module with Xbee Extension and will try in next few days. Can you check "UBL1.IMG size is it 14KB only? as I only 14KB get after unzipping.
2017-09-20 22.38.40.jpg


2017-09-24 13.28.58.jpg
 
Last edited:
Joined
Mar 30, 2017
Messages
11
Reaction score
3
Location
Ireland, Dublin.
Have to mention normal SD card updates are failing on both boards, and flashing with this usb to serial adapter, I have tried both methods with p3p board connected to the bird, and second power connected thru USB serial adapter with 3.3v and 5v and same results as in the first picture. Appreciate any help, thanks.
 
Joined
Mar 30, 2017
Messages
11
Reaction score
3
Location
Ireland, Dublin.
Hey all, just want to say big THANK YOU to "SunsetCatcher" and other people who found this fix! I just successfully fixed two P3P boards with this fix, the only problem for me was wrong command prompt directory...? and when finally learned where my IMG files are extracted and how to point the command line to that place everything was done in first time and 100% successfully now I have live video back. Thanks again to all!!!!
 
Joined
Jun 5, 2017
Messages
60
Reaction score
27
Location
raxxla
Have to mention normal SD card updates are failing on both boards, and flashing with this usb to serial adapter, I have tried both methods with p3p board connected to the bird, and second power connected thru USB serial adapter with 3.3v and 5v and same results as in the first picture. Appreciate any help, thanks.
You run from c:? Without folders. And may be you nand broken after crash
 
Joined
Sep 24, 2017
Messages
4
Reaction score
2
Age
66
Hi Drons, just trying to follow your wiring, have I got this right?
1. Boot0 and Boot1 shorted out with lead going to 3.3V on P3P board.
2. Lead from 3.3V on USB to TTL FT232RL board to 3.3V on P3P board.
3. Lead from 5V on USB to TTL FT232RL board to 5V on P3P board.
I think I'm ok with the other connections but I will add my understanding to check if I've got it right.!
4. Lead from GND on USB to TTL FT232RL board to GND on P3P board.
5. Lead from Rx on USB to TTL FT232RL board to Tx on P3P board.
6. Lead from Tx on USB to TTL FT232RL board to Rx on P3P board.
Many thanks for you and SunsetCatcher's help.
 
  • Like
Reactions: genem56
Joined
Mar 30, 2017
Messages
11
Reaction score
3
Location
Ireland, Dublin.
Hi Drons, just trying to follow your wiring, have I got this right?
1. Boot0 and Boot1 shorted out with lead going to 3.3V on P3P board.
2. Lead from 3.3V on USB to TTL FT232RL board to 3.3V on P3P board.
3. Lead from 5V on USB to TTL FT232RL board to 5V on P3P board.
I think I'm ok with the other connections but I will add my understanding to check if I've got it right.!
4. Lead from GND on USB to TTL FT232RL board to GND on P3P board.
5. Lead from Rx on USB to TTL FT232RL board to Tx on P3P board.
6. Lead from Tx on USB to TTL FT232RL board to Rx on P3P board.
Many thanks for you and SunsetCatcher's help.
Hi, yes I think you got all wiring connections right, you also can connect only RX and TX from P3P board with FT232RL board, and connect P3P board directly to drone and power drone on(just disconnect flex ribbon cable), I found both methods working for me.
 
Joined
Sep 19, 2017
Messages
18
Reaction score
4
Age
39
Hopefully someone can help me out and tell me what im doing wrong. I have followed all the instructions, connected everything as it should be and once i run the command it just sits waiting for the dm36x. the board flashes green for a little bit then turns off then flashes again.
 

Attachments

  • screenshot.jpg
    screenshot.jpg
    68.9 KB · Views: 1,143
Joined
Jun 5, 2017
Messages
60
Reaction score
27
Location
raxxla
Hopefully someone can help me out and tell me what im doing wrong. I have followed all the instructions, connected everything as it should be and once i run the command it just sits waiting for the dm36x. the board flashes green for a little bit then turns off then flashes again.
Check you com port in device manager, com5 this com port in my system, you have another number.
 
Joined
Jun 5, 2017
Messages
60
Reaction score
27
Location
raxxla
Hi Drons, just trying to follow your wiring, have I got this right?
1. Boot0 and Boot1 shorted out with lead going to 3.3V on P3P board.
2. Lead from 3.3V on USB to TTL FT232RL board to 3.3V on P3P board.
3. Lead from 5V on USB to TTL FT232RL board to 5V on P3P board.
I think I'm ok with the other connections but I will add my understanding to check if I've got it right.!
4. Lead from GND on USB to TTL FT232RL board to GND on P3P board.
5. Lead from Rx on USB to TTL FT232RL board to Tx on P3P board.
6. Lead from Tx on USB to TTL FT232RL board to Rx on P3P board.
Many thanks for you and SunsetCatcher's help.

1 true
2 false, don't connect 3.3v from ftdi to board
3,4,5,6 true
 
Joined
Sep 19, 2017
Messages
18
Reaction score
4
Age
39

Recent Posts

Members online

No members online now.

Forum statistics

Threads
142,156
Messages
1,461,104
Members
103,946
Latest member
xr2