P3 Firmware P3P No image transmission signal

Joined
May 4, 2024
Messages
5
Reaction score
9
Age
29
The AC connects to the RC and I can takeoff/land/fly/move gimbal/etc. but it tells me that there is "no image transmission signal" (and obviously I don't see a live camera feed).
Phantom 3 Professional
App Version 3.1.68
Aircraft Version 1.11.20
Remote controller Version 1.9.2
iPhone iOS Version 17.4.1
I have tried with formatted SD card, no SD card, and multiple cables to phone. I have deleted and reinstalled the app. I do not have an older phone/device to try but I suppose I could buy one if necessary.
Any ideas?
Thanks!
 
Last edited:
  • Like
Reactions: RodPad
The AC connects to the RC and I can takeoff/land/fly/move gimbal/etc. but it tells me that there is "no image transmission signal" (and obviously I don't see a live camera feed).
Phantom 3 Professional
App Version 3.1.68
Aircraft Version 1.11.20
Remote controller Version 1.9.2
iPhone iOS Version 17.4.1
I have tried with formatted SD card, no SD card, and multiple cables to phone. I have deleted and reinstalled the app. I do not have an older phone/device to try but I suppose I could buy one if necessary.
Any ideas?
Thanks!
This sounds like a bad video board in the remote. I don't recall exact part names or numbers, but the behavior sounds like a common hardware problem in the remote.
 
  • Like
Reactions: RodPad
@Johnboy94
Welcome to the forum!

Yes, don't need a SD for the camera.

What I'm missing, are you getting all the data on your phone except the image?

When was the last time this P3P worked correctly?.

Rod ..
 
@Johnboy94
Welcome to the forum!

Yes, don't need a SD for the camera.

What I'm missing, are you getting all the data on your phone except the image?

When was the last time this P3P worked correctly?.

Rod ..
Yes, everything but the live image is working. GPS, altitude, speed, battery %, etc.
It can even take photos and save them to the SD and they appear clear when back on the computer. I cannot however, view the captured photos through the phone connection after pressing the RC media button. It shows how many are there but not the images themselves.
It has actually never worked correctly... It was entirely unopened and in its original case until earlier this week. I had to purchase new batteries for it as it wouldn't charge but now that that's working we've hit another roadblock.
Thanks!
 
Yes, everything but the live image is working. GPS, altitude, speed, battery %, etc.
It can even take photos and save them to the SD and they appear clear when back on the computer. I cannot however, view the captured photos through the phone connection after pressing the RC media button. It shows how many are there but not the images themselves.
It has actually never worked correctly... It was entirely unopened and in its original case until earlier this week. I had to purchase new batteries for it as it wouldn't charge but now that that's working we've hit another roadblock.
Thanks!
Hum, I look for the facts (History)

There is a lot of knowledge on this forum!
Members that will help out.

"It was entirely unopened and in its original case until earlier this week."

The question.
This was brand new in the box?

Rod ..
 
Hum, I look for the facts (History)

There is a lot of knowledge on this forum!
Members that will help out.

"It was entirely unopened and in its original case until earlier this week."

The question.
This was brand new in the box?

Rod ..
I guess it wasn't brand new "in box" but it had never been flown before. All of the packing foam and gimbal lock were all still in place. Original owner was too scared to fly it because of a friend who totaled 2 of the same drone before she had it. I'm unsure if it was ever turned on but the 8 props it came with all still had their plastic coverings over the mounting threads.

From what I've read, updating firmware from a very early version to the most current has a tendency to brick the board in the gimbal and most people replace the entire gimbal at that point.

As the entire drone runs for about the cost of a gimbal (as they don't make em anymore and I don't want to buy uysed because I suspect that the used gimbals are from others this has happened to) I may just say F it, return the batteries to amazon as they were charged once and no longer needed, and just buy a new one (mini 4 pro?)

Of course if someone has something to try before I return these batteries I'm all for it!
 
I know you mentioned you had tried 'multiple cables to phone', but I'm wondering what kind of USB cables they are. Some of the cheaper ones are 'charge only'. You need a good data transfer cable to get the data from the drone to the phone/ display device. Just a thought. Hope you get it sorted out.
 
  • Like
Reactions: RodPad
I know you mentioned you had tried 'multiple cables to phone', but I'm wondering what kind of USB cables they are. Some of the cheaper ones are 'charge only'. You need a good data transfer cable to get the data from the drone to the phone/ display device. Just a thought. Hope you get it sorted out.
Unfortunately that’s not the problem, I checked to see if it was good by connecting my phone to my computer and it connected there no problem. Thanks though!
 
First time I been back on today.

This guy might have some thoughts.

@msinger
Help sight may have some help.

Rod ..
 
  • Like
Reactions: captainmilehigh
The AC connects to the RC and I can takeoff/land/fly/move gimbal/etc. but it tells me that there is "no image transmission signal" (and obviously I don't see a live camera feed).
Phantom 3 Professional

Thanks!
There are 2 causes of loss of video
1) damaged cable after a crash that has been replaced but has blown the mainboard
2) long term storage causes the issue.

If its 1 then there is little chance of a fix, only buying a new camera
if its 2 then follow my video guide below, it works on about 75% of the ones I have been sent for repair


 
  • Like
Reactions: BigL and RodPad
@crash1sttime
Thanks, I see my last post wasn't wanted it to look like.

Rod ..
 
  • Like
Reactions: crash1sttime
There are 2 causes of loss of video
1) damaged cable after a crash that has been replaced but has blown the mainboard
2) long term storage causes the issue.

If its 1 then there is little chance of a fix, only buying a new camera
if its 2 then follow my video guide below, it works on about 75% of the ones I have been sent for repair


I'd never seen one of those rotating pcb holders before! Looked up rotating pcb board holder on ebay and sure enough, 23 bucks. Thanks for showing it.
 
  • Like
Reactions: RodPad
I'd never seen one of those rotating pcb holders before! Looked up rotating pcb board holder on ebay and sure enough, 23 bucks. Thanks for showing it.

I do/did a lot of repairs for the P3 and P2 and originally was putting it on a cardboard box with a hole cut in for the connector underneath, I found that on ebay quite accidentally one day and never looked back, its great for the Phantom 2 Vision repair as you need to turn the board over to touch a component to put it in boot mode.

I have since moved onto a new method which uses pogo pin clamps shown in the video below, these work for the Vision and Vision plus baords

 
  • Love
Reactions: RodPad

Members online

No members online now.

Forum statistics

Threads
143,153
Messages
1,468,001
Members
105,051
Latest member
stovesparesdirectuk