Litchi FPV Screen Horizon Obscured by "Zebra Crossings"

Joined
Aug 17, 2020
Messages
90
Reaction score
34
Age
35
I acquired Litchi specifically to fly pre-planned autonomous missions, so in this regard it has performed flawlessly and above my expectations. The work-around solution to address the lack of gimbal tilt control when flying beyond signal range, has been solved by contributors to this forum, who advise disabling the gimbal tilt facility for all waypoints, and then manually setting the gimbal to the desired angle right after takeoff, but BEFORE pressing the play button to commence each mission, whereby that initial manually fixed gimbal tilt angle is maintained for the entire flight, regardless of controller signal limitations.

The problem I have encountered in manually setting that gimbal angle, is that for all of my most recent flights with Litchi, the sky and horizon view, on my iPad, has been completely obscured by strange black and white bars that resemble the zebra crossing markings seen on city roadways. Additionally, those zebra crossing markings also appear on any bright or shiny surfaces such as roofs, or puddles of water on the ground, that are visible on my iPad's FPV screen during flights using Litchi. With those annoying bars completely obscuring the horizon in my iPad's FPV view of the flight, it is practically impossible to manually set the gimbal tilt to the desired angle, with the result that I would up turning the camera almost vertically downward for my last flight, pretty much ruining all the footage.

I would be very grateful if anyone can explain how I can go about getting rid of those strange zebra crossing markings that prevent me from seeing the FPV screen horizon, and thus make my initial gimbal tilt efforts a trial-and-error, hit-or-miss endeavor, rather than the simple precise adjustment that I expect to be able to perform when I go to frame my camera's gimbal view for each flight. Those strange markings do not appear at all in the recorded footage, but only in the FPV footage, and also, there are no such problems in the FPV view when I use DJI Go. I am pulling my hair out here, over trying to figure out why the horizon is so completely obscured by those odd markings, yet I have no idea how to get rid of them, so I can regain full control of my camera view when using Litchi. Thanks in advance for any help that can be offered.
 
Joined
Aug 17, 2020
Messages
90
Reaction score
34
Age
35
Ok well I found out that the downward facing gimbal was not due to my being unable to discern the true horizon on account of those mysterious zebra crossing markings on Litchi's FPV view. The gimbal was tilted too far down simply because I set the first two waypoints at a -42 degree downward tilt, due to having read in this forum several references to -42 degrees as being the optimal downward tilt to which the first couple of waypoints only, should be set, so as to retain that tilt for the entire flight, by virtue of all subsequent waypoints having their gimbal tilt option disabled.

Turns out that for my Phantom 3S, a downward tilt of -42 degrees is WAY too far down, so, I went ahead and disabled the gimbal tilt for ALL waypoints, and then manually set the gimbal on takeoff, but prior to pressing the play button to start the mission. The zebra crossings are a minor irritation, but not so much as to prevent me setting the gimbal tilt such that only a small sliver of horizon and sky is visible in the FPV screen, just the way I like it.

In short, to achieve perfect gimbal angles for all your beyond signal range Litchi flights, you MUST disable the gimbal tilt option for ALL waypoints, so that you can manually set the horizon as far up the screen you want it for the entire flight, before starting the mission by pressing the play button. I now have ZERO complaints with Litchi. It is truly one wondrous work of software engineering, that dramatically extends the range of the lowly Phantom 3S.

As for those zebra crossings, I will live with that anomaly, since it is of minimal importance when setting the camera angle for a flight, and also, since it does NOT appear in the recorded video footage. In short, if your new girlfriend looks like a Playboy centerfold model, she can forgiven for not holding a PhD in Particle Physics from MIT, all things considered.
 
Joined
Aug 17, 2020
Messages
90
Reaction score
34
Age
35
The zebra stripes you describe sound like overexposure warning stripes. The overexposure warning can be disabled in Litchi settings.

Aha ! Eureka. Much obliged sir. I'll look into that settings menu, and get rid of the warning bars. You are a gentleman and a scholar, if I may say so, and I thank you kindly. Hopefully I'll be able to restore factory settings so that the camera auto-compensates for excessive brightness.
 
Last edited:
Joined
Jul 29, 2016
Messages
427
Reaction score
215
Age
77
Be warned that auto exposure often produces bumps in the exposure as it compensates for changing subject brightnesses. I always set my exposure manually, use cinema-d settings, and fix the exposure in post. This requires setting the exposure manually to a Setting where neither whites or blacks are clipping.
 
Joined
Aug 17, 2020
Messages
90
Reaction score
34
Age
35
Please forgive my ignorance in these matters, Mr. Cambridge, but could you describe where I can access camera settings within the Litchi app ? I am assuming that such settings don't require DJI Go, before switching over to Litchi for the actual flight. I haven't any experience with video editing at all, and have never tried such procedures as yet.
 
Joined
Aug 17, 2020
Messages
90
Reaction score
34
Age
35
I momentarily forgot about the old search button. Found my question about adjusting camera exposure level, answered back in 2016.

 
Joined
Aug 17, 2020
Messages
90
Reaction score
34
Age
35
Hmm I found a camera setting for "Sunny", and selected that option, but the zebra stripes are still present, so next I'll try a fully manual adjustment, to see how that works in banishing the zebra stripes. Recorded footage has been way too bright, even when I set the camera to exclude all but a narrow sliver of sky above the horizon. Oddly enough, this marking doesn't appear at all with DJI Go, so presumably Litchi is a lot more sensitive to over-exposure.
 
Last edited:

Oso

Premium Pilot
Joined
May 19, 2015
Messages
4,754
Reaction score
3,800
Location
Western US
Oddly enough, this marking doesn't appear at all with DJI Go, so presumably Litchi is a lot more sensitive to over-exposure.
Perhaps the over exposure warning is disabled in GO but still enabled in Litchi.
 
  • Like
Reactions: dirkclod

New Threads

Members online

Forum statistics

Threads
139,778
Messages
1,441,811
Members
101,509
Latest member
ZiyueXiao