issues with staying connected.......

Joined
May 12, 2015
Messages
28
Reaction score
4
Age
40
Had my first flight on a P3 advanced. First 5 min was great. Everything working fine....then all of a sudden it started getting "disconnected" and the screen going black and white!!!! I brought it down immediately. It wouldn't stay connected anymore....saying that I need to make sure I'm not near any metal objects....which I wasn't. In fact I hadn't moved at all. Screen shot is attached. It wouldn't let me recalibrate either. I'm a bit frustrated but happy that at least I didn't crash it. Lol
Ps. I Uninstalled and reinstalled the app but no luck.


Anyone have any ideas?
 

Attachments

Joined
Feb 3, 2015
Messages
3,858
Reaction score
1,149
Location
Long Island, NY
Change your location and report back.
 
Joined
Dec 16, 2014
Messages
534
Reaction score
214
Location
North Carolina US
I guess he means walk 300ft north and try again. making sure your antennas are up correctly

and re-calibrate compass per error report.....
 
Joined
May 12, 2015
Messages
28
Reaction score
4
Age
40
I took it to a soccer field. Completely open. No difference in behavior. Still cannot recalibrate. When click on 'mode', then click on 'calibrate compass' and click ok, It doesn't do or say anything else. I even go through the procedures to calibrate it but it does not show the animation like it did the first time I flew this, nor does it give any error messages. It just simply doesn't say anything. I can still fly the drone but the camera does not work and I do not show to be connected. Please help. This is very frustrating considering how excited I was to get this.
 
Joined
Jan 16, 2015
Messages
644
Reaction score
251
I took it to a soccer field. Completely open. No difference in behavior. Still cannot recalibrate. When click on 'mode', then click on 'calibrate compass' and click ok, It doesn't do or say anything else. I even go through the procedures to calibrate it but it does not show the animation like it did the first time I flew this, nor does it give any error messages. It just simply doesn't say anything. I can still fly the drone but the camera does not work and I do not show to be connected. Please help. This is very frustrating considering how excited I was to get this.
Make sure you have usb debugging enabled....and/or try a different device.....for some reason my note 4 hates it too....but i have no issues with my Tab S 8.4
 
Joined
Oct 27, 2013
Messages
159
Reaction score
16
Location
Colorado
Did. You try killing the app a
I took it to a soccer field. Completely open. No difference in behavior. Still cannot recalibrate. When click on 'mode', then click on 'calibrate compass' and click ok, It doesn't do or say anything else. I even go through the procedures to calibrate it but it does not show the animation like it did the first time I flew this, nor does it give any error messages. It just simply doesn't say anything. I can still fly the drone but the camera does not work and I do not show to be connected. Please help. This is very frustrating considering how excited I was to get this.
did you try killing the app and restarting it. I know you said you reinstalled but did you try to recalibrate after reinstall or after a test flight with the app? I flew mine last weekend and forgot to calibrate the compass and I was getting very strange readings. Nothing made any sense on the screen. I landed the drone and clicked on calibrate. Went thru the motions and then everything worked great. Yes, I did get the animate promts while calibrating.
 
Joined
May 12, 2015
Messages
28
Reaction score
4
Age
40
Did. You try killing the app a

did you try killing the app and restarting it. I know you said you reinstalled but did you try to recalibrate after reinstall or after a test flight with the app? I flew mine last weekend and forgot to calibrate the compass and I was getting very strange readings. Nothing made any sense on the screen. I landed the drone and clicked on calibrate. Went thru the motions and then everything worked great. Yes, I did get the animate promts while calibrating.
I did restart. Can you tell me exactly what you click on in order to calibrate?
 
Joined
Oct 27, 2013
Messages
159
Reaction score
16
Location
Colorado
I did restart. Can you tell me exactly what you click on in order to calibrate?
I'm traveling now so I can't take a screen shoot. I believe you hit the button that says ready to fly on the top middle of the screen. There you will see the calibration button.
 
Joined
May 14, 2015
Messages
10
Reaction score
0
Location
merica
I had same issue right away. I was between multiple people with WiFi Bluetooth and tv. Just walk across the room away from all that and try again.
 
Joined
May 12, 2015
Messages
28
Reaction score
4
Age
40
OP here. Hopefully the info below will help someone else:

My issue seems to have been resolved.
I took the P3 to an open field (again) and had the exact same "disconnected" problem. it wouldn't let me calibrate. SO, i uninstalled the app. restarted my Note 4 phone. took the battery out of the P3. re installed the app. Opened the app. turned on the P3. and it immediately recognized it and allowed me to re calibrate. I made sure to do the calibration at 1.5 meters from the ground as instructed.

Anyway, it worked like a charm after that. no issues for the next 15 or so minutes. Can't wait to have my second real flight tomorrow :-D
 
  • Like
Reactions: J.James and bbfpv
Joined
May 14, 2015
Messages
9
Reaction score
3
Age
50
Any progress? I just upgraded my Phantom 3 Advance firmware, and can't get the Pilot App to connect on my Galaxy S5. Prior to firmware update it was a bit flaky before with video in the camera function going to black and white before freezing at times. But now I can't get any connection to show in the pilot app. So I have no ability to calibrate the bird. Controller still talks fine to the bird with flight and gimbal controls working ok.

I've tried various cables, various bird-controller-app startup patterns, reooting and clearing cache on my phone. Wifi on the phone is off.

I've only flown it about 6 times so I'm trying to understand what is 'normal behavior'. One other clue may be that when upgrading the controller, I got the blue dot, but did not get any text files added to my thumb drive.
 

New Threads

Forum statistics

Threads
139,306
Messages
1,437,347
Members
101,179
Latest member
UAmetry