Issue with Pitch/Tilt on Goodluckbuy Gimbal on Phantom 2

Joined
Mar 22, 2015
Messages
346
Reaction score
99
Location
Phoenix
Hey guys!
So I installed one of the Goodluckbuy gimbals on my Phantom 2 today, and it powers up and works fine with the exception of the pitch. I turn the pitch wheel on the controller, and nothing - no action. Setting this up should be straight forward. I have the correct pin (top left) wired into the bottom F2 port. So I don't know if its just settings or possibly something wrong with my gear. My dad has the same setup, and we worked on this together setting up mine the same way as his, yet his works and mine doesn't.

Anyone had this issue or have ideas of how I could troubleshoot?
Is it possible that I need to check the wires inside my transmitter to be sure everything is ok with the connections to the wheel? Not really sure where to go from here, but this is a bummer!

Thanks in advance guys!
 
Joined
Jan 16, 2015
Messages
644
Reaction score
251
Any ideas guys? I'm at a loss
Go into the dji assistant software and confirm that you have it set to "upgraded transmitter"
Also i think you want the pitch gain setting on the gimbal setup page in dji assistant software Set to 0.
 
Joined
Mar 22, 2015
Messages
346
Reaction score
99
Location
Phoenix
You were right that it was my settings within the software. Had to go to Basic/RC/X1 calibration and calibrate the pitch wheel. Good to go now!
Here is my test footage:

Only issue I have left is that the gimbal over-compensates when the Phantom tips forward and backward. Hope someone comes out with good firmware for the generic gimbal. The SBGC software doesn't seem consistent with it yet. Kinda hit and miss. But so far I think its all there is for this setup.
 
Joined
Jan 16, 2015
Messages
644
Reaction score
251
Good to hear.....for the other issue....have you made sure in the dji software that the gimbal Pitch Gain is set to 0......double check that....may fix the issue....good luck
 
  • Like
Reactions: Falcondrone
Joined
Mar 22, 2015
Messages
346
Reaction score
99
Location
Phoenix
Hey thanks for the input. I just gave that a shot but no dice. Probably because its an aftermarket gimbal as opposed to the Vision gimbal. The gimbal I installed only connects to the phantom by way of power and tilt control. I have the SBGC software for the gimbal, but since Im using a $50 knockoff from goodluckbuy, changing settings seems hit and miss. Changes don't always save or seem to be consistent. And I've read that updating the firmware on these things will brick them, so haven't attempted that.
 
Joined
Apr 2, 2015
Messages
180
Reaction score
73
Location
Rapid City, SD
You were right that it was my settings within the software. Had to go to Basic/RC/X1 calibration and calibrate the pitch wheel. Good to go now!
Here is my test footage:

Only issue I have left is that the gimbal over-compensates when the Phantom tips forward and backward. Hope someone comes out with good firmware for the generic gimbal. The SBGC software doesn't seem consistent with it yet. Kinda hit and miss. But so far I think its all there is for this setup.

I had the same issue. And as Louforgiveno already said, the DJI assistant settings need to be adjusted, they are defaulted to Pitch and Roll at 30 (in my assistant settings anyway). Make sure you set them both to 0 and hit enter adter every time you enter the number. Make sure the values are save before you disconnect, otherwise it will go back to the old value.

That is the only thing that fixed my gimbal from overcompensating after pitch input. This was a great fix to my problem I'm not sure if you have the same documentation with your China Gimbal, however step 6 on mine gave a rather bad picture of the screenshot.

Hope you get it fixed...
 
Joined
Mar 22, 2015
Messages
346
Reaction score
99
Location
Phoenix
I had the same issue. And as Louforgiveno already said, the DJI assistant settings need to be adjusted, they are defaulted to Pitch and Roll at 30 (in my assistant settings anyway). Make sure you set them both to 0 and hit enter adter every time you enter the number. Make sure the values are save before you disconnect, otherwise it will go back to the old value.

That is the only thing that fixed my gimbal from overcompensating after pitch input. This was a great fix to my problem I'm not sure if you have the same documentation with your China Gimbal, however step 6 on mine gave a rather bad picture of the screenshot.

Hope you get it fixed...

Thanks Instuder. Which software version are you using? I'm using P2 3.8 and don't see that setting anywhere. In the gimbal config settings it just shows Tilt Control Gain, Horizontal Limit, and Vertical Limit. Changing these settings doesn't seem to have any direct affect. Could you be more specific on where to change these? Thanks!

I should also mention I don't believe I have the Naza version. Just reg P2
 
Last edited:
Joined
Apr 2, 2015
Messages
180
Reaction score
73
Location
Rapid City, SD
Thanks Instuder. Which software version are you using? I'm using 3.8 and don't see that setting anywhere. In the gimbal config settings it just shows Tilt Control Gain, Horizontal Limit, and Vertical Limit. Changing these settings doesn't seem to have any direct affect. Could you be more specific on where to change these? Thanks!

In the Assistant software, change the Phantom mode on the top right to NAZA M. (It will give you a notice to make sure you want to change modes, I suggest you learn about all the possibilities of the new side of software) Then under the Advanced tab you can find more gimbal settings. Set the automatic Control gain to 0 on both, and the servo travel limit to 900/0/-250.

That should do the trick for the pitch and also the travel up and down. Also this NAZA M mode allows to customize the IOC Intelligent Orientation Control and S1 switch.

Lots of options...

Hav fun.
 
Joined
Mar 22, 2015
Messages
346
Reaction score
99
Location
Phoenix
In the Assistant software, change the Phantom mode on the top right to NAZA M. (It will give you a notice to make sure you want to change modes, I suggest you learn about all the possibilities of the new side of software) Then under the Advanced tab you can find more gimbal settings. Set the automatic Control gain to 0 on both, and the servo travel limit to 900/0/-250.

That should do the trick for the pitch and also the travel up and down. Also this NAZA M mode allows to customize the IOC Intelligent Orientation Control and S1 switch.

Lots of options...

Hav fun.

I don't seem to have all those settings. Possibly because I have regular Phantom 2 and not Naza version?
 
Joined
Mar 22, 2015
Messages
346
Reaction score
99
Location
Phoenix
All I see under Gimbal settings is Tilt Control Gain, Horizontal Limit, and Vertical Limit. Setting all those to zero didn't seem to fix. One additional note, the only cable I have going into the Phantom is for tilt control. I notice when i unplug it, it balances just fine.
 
Joined
Apr 2, 2015
Messages
180
Reaction score
73
Location
Rapid City, SD
This is what I see

That is strange, my window shows more settings. I have no experience with the P2, maybe there are others that have seen both and know the difference? I will try to post a screenshot of my assistant window in just a little bit...
 
Joined
Mar 22, 2015
Messages
346
Reaction score
99
Location
Phoenix
Very strange. I feel like I'm missing something here. Maybe I should try downloading a different software version? Would u mind sending me a link to the version your using?

Thanks a ton for your help btw. This has been driving me crazy!
 
Joined
Apr 2, 2015
Messages
180
Reaction score
73
Location
Rapid City, SD
I don't seem to have all those settings. Possibly because I have regular Phantom 2 and not Naza version?
I wonder what would happen if you actually loaded the P2V software, if it is even compatible, I am thinking you now turned the P2 to a P2V... Just curious.
 
Joined
Apr 2, 2015
Messages
180
Reaction score
73
Location
Rapid City, SD
Very strange. I feel like I'm missing something here. Maybe I should try downloading a different software version? Would u mind sending me a link to the version your using?

Thanks a ton for your help btw. This has been driving me crazy!
Its on the DJI website

http://www.dji.com/product/phantom-2-vision/download

But make sure you install the drivers as well. Without that I had a hard time running and connecting.

Let me know if all work out. I understand the driving you crazy part. :confused:
 
Joined
Mar 22, 2015
Messages
346
Reaction score
99
Location
Phoenix
Just tried both Vision versions. It shows the same settings. I'm thinking its due to me just having the basic Phantom 2. Seems to recognize my board and default to the standard P2 options. I may be outta luck here. I've messed around for hours within the SBGC software too and can't seem to fix the pitch over-correction.

Again the strange part is if I unplug the cable that allows the tilt control, it auto balances fine with no over-correction. As soon as I reconnect, it wants to over-correct. Ugh..
 
Joined
Apr 2, 2015
Messages
180
Reaction score
73
Location
Rapid City, SD
Just tried both Vision versions. It shows the same settings. I'm thinking its due to me just having the basic Phantom 2. Seems to recognize my board and default to the standard P2 options. I may be outta luck here. I've messed around for hours within the SBGC software too and can't seem to fix the pitch over-correction.

Again the strange part is if I unplug the cable that allows the tilt control, it auto balances fine with no over-correction. As soon as I reconnect, it wants to over-correct. Ugh..


This is my screenshot... What a bummer, I was rooting for the home team.

Screenshot.png
 
Joined
Apr 2, 2015
Messages
180
Reaction score
73
Location
Rapid City, SD
Bummer! Thanks for trying man. Must be a limitation having a P2
I'll try to research some more. I know how frustrating the overcorrection is:

 

New Threads

Members online

Forum statistics

Threads
140,724
Messages
1,450,243
Members
102,547
Latest member
Jcampanur