Standard Ipad Models for Phantom 3 Standard

Joined
Jul 18, 2021
Messages
12
Reaction score
2
Age
27
I am wanting to get a used ipad to use with my phantom 3 standard as I prefer the bigger screen when flying. So I am curious, what is the oldest model ipad one can use. When I used an old iphone 5s running 12.5.4 the connection between the phone and the drone was to sporadic to work while when I used my current iphone 8 running 14.6 I had no problems. So I know from this experience that older ios products may not work as well.

Thanks
 
Joined
Aug 12, 2021
Messages
29
Reaction score
15
Age
65
I am wanting to get a used ipad to use with my phantom 3 standard as I prefer the bigger screen when flying. So I am curious, what is the oldest model ipad one can use. When I used an old iphone 5s running 12.5.4 the connection between the phone and the drone was to sporadic to work while when I used my current iphone 8 running 14.6 I had no problems. So I know from this experience that older ios products may not work as well.

Thanks
I use a Ipad Air 2 . I fly a Phantom 4 Pro with it . They get hot in the sun and you loos the picture . I also have the Mavic Air 2
and fly with the Smart Controller , wish it worked with P4P . But when I bought my Phantom 4 Pro I did the research and the
Ipad Air 2 was the best choice . Can't say now one of the newer Ipads may be a better choice like the Ipad Pro .
 

Capt KO

Capt KO
Joined
Feb 13, 2019
Messages
2,581
Reaction score
2,158
Age
70
Location
IRB, Fl
I’m using both an iPad mini 4 and the larger iPad 5th gen successfully with GO. Both available used at good prices and work well with GO and GO4. If thinking of using FLY app in the future the iPad 5th gen works well but the Mini should be a 5. Go and Go4 work best with a cpu of 1.4 or above but latest Fly needs 1.8 or above.
 
  • Like
Reactions: WV. Rootman
Joined
May 1, 2017
Messages
3,647
Reaction score
2,963
Age
68
Location
N.central wv. U.S.
I’m using both an iPad mini 4 and the larger iPad 5th gen successfully with GO. Both available used at good prices and work well with GO and GO4. If thinking of using FLY app in the future the iPad 5th gen works well but the Mini should be a 5. Go and Go4 work best with a cpu of 1.4 or above but latest Fly needs 1.8 or above.
You teach me so much. Good to know. I will definitely put your knowledge to work for me in buying my next drone. Whenever I can work that out. Lol.
He wanted to know which I pad works for the P3s.
 
Joined
Jul 18, 2021
Messages
12
Reaction score
2
Age
27
I also want to use Pix4D Capture with the Phantom 3 Standard. Would this also impact what version of ipad I can use?
 
Joined
Sep 24, 2020
Messages
22
Reaction score
3
Age
62
I’m using both an iPad mini 4 and the larger iPad 5th gen successfully with GO. Both available used at good prices and work well with GO and GO4. If thinking of using FLY app in the future the iPad 5th gen works well but the Mini should be a 5. Go and Go4 work best with a cpu of 1.4 or above but latest Fly needs 1.8 or above.
Capt,
Have you used the DJI GS Pro successfully with the 5th Generation iPad and GL300B RC? The DJI GS Pro app will not show the RC and AC linked. But with the DJI GO app, it is linked so I can fly and capture imagery with the DJI GO app. Using a P3ADV for AC.

Thanks,
 

New Threads

Members online

No members online now.

Forum statistics

Threads
141,474
Messages
1,455,957
Members
103,259
Latest member
matheus moura da silva