Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Help!!!! Can't keep wifi connection on two P2V+'s!!!

Discussion in 'Phantom 2 Vision + Help' started by Monkeyleg, Aug 1, 2015.

  1. Monkeyleg

    May 13, 2015
    Likes Received:
    Today seems to be the day for wifi problem posts.

    I have a P2V+ v3.0 I got a couple of months ago in trade. It's been problem-free as far as wifi. I've always gotten a good connection (2200 feet) and good video.

    Yesterday in the mail came a P2V+ v2.0 I'd bought on Ebay, with a broken gimbal. I hooked everything up and tried it with my Iphone 5. "Cannot join network". I re-binded the repeater to the craft. The connection lasted less than thirty seconds before it dropped and I got the "Phantom connection lost" message in the Vision app.

    I thought maybe something was wrong with the main board on the gimbal, so I tried a gimbal I already had that I know worked. Same thing.

    I tried re-binding different ways several times: turn off repeater and Phantom right after binding, keep both on after binding, hold reset button down until LED goes out, hold reset button down after LED goes out until LED comes back on, etc. Then thought I'd try the repeater from my v3.0. Same problem. I also was not able to get video from either the v3.0 or the v2.0. Cameras I knew worked.

    Just to be sure about things, I tried my v3.0 with its repeater and the gimbal I usually have on it. It worked.

    After doing hours of searching on the internet and trying this and that, I found the v3.0 wouldn't connect.

    I figured it had to be the phone or the app, so I hooked up the Iphone to my PC and restored the phone to factory defaults, then downloaded the app again. No luck. Same thing.

    I tried letting both birds cool down in case the wifi modules were getting too warm. That didn't help. I tried the v2 repeater with the v3 bird, but no luck. I checked connections many times. I checked the settings on the iPhone, which I hadn't changed from before this all started.

    I was up until 6 an messing with this, got 4 hours sleep, then started in again. I finally figured it had to be the phone, so I called Walmart, but they only sell phones with plans. I borrowed another iPhone from a neighbor, downloaded the app, checked to make sure Bluetooth was off, Airplane setting was off, Cellular Data was off, and other things. I tried both Phantoms with it, but no luck. I tried re-binding with both Phantoms, but that didn't work. I tired several things. The new phone didn't make a difference at all.

    I downloaded a couple of apps that allow you to check for wifi connections, and which should have shown the wifi modules, but they didn't show up.

    Another weird thing is that, when I went to bed, I plugged in batteries, repeaters and controllers to recharge. When I got up and checked both the Phantoms, the v3.0 was bound. I turned it off and on and everything worked. When I changed to another gimbal, the connection was lost.

    I cannot think of another thing to check.

    Any suggestions on what else to do? There's probably something really obvious I'm missing.
    #1 Monkeyleg, Aug 1, 2015
    Last edited: Aug 1, 2015
Similar Threads - Help Can't keep Forum Date
P3 Firmware 3adv Firmware - can't update AC or RC - please help! Firmware Oct 8, 2017
Can't get my Phantom 4 to work - HELP! Phantom 4 Help Jul 30, 2017
Can't figure it out.....help needed !! Phantom 4 Pro Help Jul 9, 2017
Help! Somehow set language to Chinese and can't get back DJI Goggles May 26, 2017
Standard Can't find a pitch/roll motor. Need help Phantom 3 Help Feb 5, 2017