Google pixel XL Question

Joined
Sep 21, 2016
Messages
1
Reaction score
0
Age
51
Just wondering if any known problems flying withe google pixel XL. Just wondering before i purchase one. Thanks for helping.
 
Joined
Jun 26, 2015
Messages
6,222
Reaction score
2,846
Location
Yorba Linda, CA
It's high risk if it's not on DJIs list. That's not a cheap phone.
 
Joined
Jan 27, 2014
Messages
425
Reaction score
89
Age
68
Location
Ft Myers, Florida
Not sure I'd want to jump on that band wagon just yet. It may take some time to shake out the bugs. Look at Google glass.
 
Joined
Nov 18, 2016
Messages
4
Reaction score
2
Age
37
Don't know if this has been answered but I did tried the google pixel yesterday w phantom 5 and the new vr system they got using the litchi app it was very laggy the vr only worked with the little door where u set the phone open when I closed it the vr google app launched automatically which was annoying as hell for me after paying 24 bucks for the app thank God they offer the refund so cheers to google App Store for the option then I tried w dji go app and same lag it was crazy buggy then I tried my iPhone 6 plus s and it worked just fine, so conclusions of course every case is different but I wouldn't suggest to buy it just yet after we clear on that and I have to say will love litchi to be fully compatible w google new vr system since I liked as soon I used it but for now I stick to iPad and iPhone


Sent from my iPhone using PhantomPilots
 
Joined
Nov 26, 2016
Messages
1
Reaction score
1
Age
35
So I picked up a Phantom 3 Standard Thanksgiving Day at Wal-Mart for $369, my sister actually bought it and also got a 3 year warranty which was probably a great idea... anyway.

I have the Google Pixel XL and used the phone and also the Daydream headset this morning without much of a problem. In regards to Win Martinez's problem of Daydream app automatically opening when inserting the phone into the headset, I also had this problem. The way you fix it is by disabling NFC on your phone.

Later tonight I attempted to fly the P3S and had some issues... I couldn't connect DJI Go or Litchi to my P3S... I thought perhaps an update to the latest firmware (1.7.90) will fix the issue... Nope! I messed around with my phone some more and found that when I connected to the remote's SSID there's a message of no internet connection (this was expected) BUT when I opened a browser window I got another alert telling me no internet connection, do you want to stay connected to this SSID? I said yes, went back into DJI Go and still no go, I'm stating this because perhaps the phone was blocking the network connection which may lead to a problem for some.

Eventually I figured out what my problem was. I had to disable my cellular data 4G connection on the Pixel XL and everything started working as expected. I opened the DJI Go app and it immediately connected and I could see the camera view.

So to answer your question, Yes Google Pixel XL is compatible and also the VR Daydream headset with Litchi but you'll have to (easily) tweak a few settings to get it working! Hope this helps!
 
  • Like
Reactions: Dr. Klutz

Oso

Premium Pilot
Joined
May 19, 2015
Messages
4,737
Reaction score
3,775
Location
Western US
So I picked up a Phantom 3 Standard Thanksgiving Day at Wal-Mart for $369, my sister actually bought it and also got a 3 year warranty which was probably a great idea... anyway.

I have the Google Pixel XL and used the phone and also the Daydream headset this morning without much of a problem. In regards to Win Martinez's problem of Daydream app automatically opening when inserting the phone into the headset, I also had this problem. The way you fix it is by disabling NFC on your phone.

Later tonight I attempted to fly the P3S and had some issues... I couldn't connect DJI Go or Litchi to my P3S... I thought perhaps an update to the latest firmware (1.7.90) will fix the issue... Nope! I messed around with my phone some more and found that when I connected to the remote's SSID there's a message of no internet connection (this was expected) BUT when I opened a browser window I got another alert telling me no internet connection, do you want to stay connected to this SSID? I said yes, went back into DJI Go and still no go, I'm stating this because perhaps the phone was blocking the network connection which may lead to a problem for some.

Eventually I figured out what my problem was. I had to disable my cellular data 4G connection on the Pixel XL and everything started working as expected. I opened the DJI Go app and it immediately connected and I could see the camera view.

So to answer your question, Yes Google Pixel XL is compatible and also the VR Daydream headset with Litchi but you'll have to (easily) tweak a few settings to get it working! Hope this helps!
That's good info sir. I hope you'll consider posting that info in the P3S forum as well. I expect it would be helpful to other P3S owners. Cheers!
 
  • Like
Reactions: Dr. Klutz
Joined
Dec 20, 2016
Messages
7
Reaction score
1
Age
41
Later tonight I attempted to fly the P3S and had some issues... I couldn't connect DJI Go or Litchi to my P3S... I thought perhaps an update to the latest firmware (1.7.90) will fix the issue... Nope! I messed around with my phone some more and found that when I connected to the remote's SSID there's a message of no internet connection (this was expected) BUT when I opened a browser window I got another alert telling me no internet connection, do you want to stay connected to this SSID? I said yes, went back into DJI Go and still no go, I'm stating this because perhaps the phone was blocking the network connection which may lead to a problem for some.

Eventually I figured out what my problem was. I had to disable my cellular data 4G connection on the Pixel XL and everything started working as expected. I opened the DJI Go app and it immediately connected and I could see the camera view.

So to answer your question, Yes Google Pixel XL is compatible and also the VR Daydream headset with Litchi but you'll have to (easily) tweak a few settings to get it working! Hope this helps!
Yup can confirm all of what mp3markel said. If you turn mobile data back on, you lose connection to the phantom... Turn it off, it comes back on... Which sucks a little since google maps wont update in litchi anymore, not sure if this is a Nougat problem more then a Pixel problem, might flick Litchi support a email.
 
Joined
Jan 7, 2017
Messages
3
Reaction score
0
Age
44
I have the regular sized google pixel and haven't had any luck getting the DJI Go app to work with it so I have been stuck using my full sized ipad. I will try this trick of turning off the cellular data and see if it works with my Phantom 3 Standard.
 
Joined
Jan 7, 2017
Messages
3
Reaction score
0
Age
44
Yep that worked. Turned off my cellular connection and everything works great. Seems like an odd problem. Hopefully a fix will come.
 
Joined
Dec 20, 2016
Messages
7
Reaction score
1
Age
41
Yep that worked. Turned off my cellular connection and everything works great. Seems like an odd problem. Hopefully a fix will come.
I posted the question on the Litchi facebook page and they claim its a DJI API issue, guess I should get around to bugging DJI
 
Joined
Jun 24, 2016
Messages
7
Reaction score
2
Age
41
I don't have Litchi yet (found this thread while trying to look up using my Daydream with the Phantom), but I do have a Google Pixel XL. Google has added a "feature" which will automatically turn off wi-fi if you do not have an internet connection. To turn this feature off, go into your Wi-Fi settings, click the gear in the upper right corner, and turn off "Switch to cellular data automatically". That should hopefully fix this issue without having to turn off 4g every time.

As I said however, I don't have Litchi yet and weather isn't conducive to testing here until spring so I'll wait until then to pick it up, but if someone can test this in the meantime, let us know how it turns out.
 
  • Like
Reactions: Rochefort
Joined
Dec 20, 2016
Messages
7
Reaction score
1
Age
41
I don't have Litchi yet (found this thread while trying to look up using my Daydream with the Phantom), but I do have a Google Pixel XL. Google has added a "feature" which will automatically turn off wi-fi if you do not have an internet connection. To turn this feature off, go into your Wi-Fi settings, click the gear in the upper right corner, and turn off "Switch to cellular data automatically". That should hopefully fix this issue without having to turn off 4g every time.

As I said however, I don't have Litchi yet and weather isn't conducive to testing here until spring so I'll wait until then to pick it up, but if someone can test this in the meantime, let us know how it turns out.
Yup. But if you dont turn Mobile Broadband off, it wont connect to Litchi at all :( Thats the only downside.
 
Joined
Jun 24, 2016
Messages
7
Reaction score
2
Age
41
Is that even with auto-switching turned off? It sounded like it was an issue of trying to connect to the internet and was disabling the wifi. Interesting.... are there alternatives to Litchi? Also, what is the performance on the Pixel XL?
 
Joined
Dec 20, 2016
Messages
7
Reaction score
1
Age
41
Is that even with auto-switching turned off? It sounded like it was an issue of trying to connect to the internet and was disabling the wifi. Interesting.... are there alternatives to Litchi? Also, what is the performance on the Pixel XL?
You know what, I was an idiot that didnt read your post properly and assumed it was the same as what others have said... You know what they say about assuming.

I've done what others have done, which is to click on the popup that allows you to connect to the hotspot regardless of net access. I will try your suggestion in a sec and report back :)
 
Joined
Dec 20, 2016
Messages
7
Reaction score
1
Age
41
report back :)
My phone is completely missing a bunch of the settings you see in the wifi settings.



I only have a few options...
Screenshot_20170117-142020.png

However if you have developer mode enabled you can the "Mobile data always active" setting:


Screenshot_20170117-141604.png


Tested that, and it seems to work just fine. I was able to use google maps while having litchi display FPV through the camera. The Wifi settings, perhaps, were missing because I was in developer mode, or because its an Aussie version of the phone... No idea.

To get in to developer mode, if like me those settings are missing, check out:

Google Pixel: How to Enable USB Debugging

Thanks Baledin, your workaround was just the ticket.
 
Joined
Jun 24, 2016
Messages
7
Reaction score
2
Age
41
Good to hear that it led to a (better?) solution. I have the US version without developer mode on (although i usually do turn it on) and i see the options from your first picture.
 
Joined
Dec 20, 2016
Messages
7
Reaction score
1
Age
41
Good to hear that it led to a (better?) solution. I have the US version without developer mode on (although i usually do turn it on) and i see the options from your first picture.
Not sure if better or the same, just in a different spot. You did ask about performance before too, seems no better/worse then the DJI App, I've yet to try VR yet. It is on my todo list... Even though I think technically its illegal in Australia... Our laws are a joke.
 
Joined
Jun 24, 2016
Messages
7
Reaction score
2
Age
41
It's technically illegal in the US I'm surmising as well, since you are required to be within sight of the drone and you can't really see your drone while you have your eyes covered. Hopefully I'm wrong on this one though. ;-)
 
Joined
Jan 28, 2017
Messages
1
Reaction score
0
Age
37
So I picked up a Phantom 3 Standard Thanksgiving Day at Wal-Mart for $369, my sister actually bought it and also got a 3 year warranty which was probably a great idea... anyway.

I have the Google Pixel XL and used the phone and also the Daydream headset this morning without much of a problem. In regards to Win Martinez's problem of Daydream app automatically opening when inserting the phone into the headset, I also had this problem. The way you fix it is by disabling NFC on your phone.

Later tonight I attempted to fly the P3S and had some issues... I couldn't connect DJI Go or Litchi to my P3S... I thought perhaps an update to the latest firmware (1.7.90) will fix the issue... Nope! I messed around with my phone some more and found that when I connected to the remote's SSID there's a message of no internet connection (this was expected) BUT when I opened a browser window I got another alert telling me no internet connection, do you want to stay connected to this SSID? I said yes, went back into DJI Go and still no go, I'm stating this because perhaps the phone was blocking the network connection which may lead to a problem for some.

Eventually I figured out what my problem was. I had to disable my cellular data 4G connection on the Pixel XL and everything started working as expected. I opened the DJI Go app and it immediately connected and I could see the camera view.

So to answer your question, Yes Google Pixel XL is compatible and also the VR Daydream headset with Litchi but you'll have to (easily) tweak a few settings to get it working! Hope this helps!
Could you tell what settings you need to tweak? I'm trying to use Litchi app with Mavic, VR headset is Daydream vr and I have regular Pixel phone. The issue is that i see double image. Adjusting Depth Offset doesn't seem to do anything to fix it...
 

New Threads

Members online

Forum statistics

Threads
139,555
Messages
1,439,696
Members
101,344
Latest member
ekenenwosu577