Gimbal freaking out after replacing yaw arm

Joined
Apr 15, 2015
Messages
63
Reaction score
9
Age
39
Crashed and broke yaw arm. Replaced and upon startup the gimbal is freaking out.

Is this damage resulting from crash or did I make an error in putting it back together? I saw one video stressing importance of camera orientation but I thought I adhered to advice.

Thanks in advance.

20160603_172151.mp4
 
Joined
Feb 16, 2016
Messages
55
Reaction score
12
Location
Maui
youtube.com/watch?v=Je1TCDqRd9w

I had similar issue and then followed this helpful video to address my install errors.
 
Joined
Apr 15, 2015
Messages
63
Reaction score
9
Age
39
Well I just decided to leave it running and check the app for feed and noticed there was none so definitely done damage to camera or ribbon. I believe I connected all terminals correctly to enable all functionality
 
Joined
Nov 23, 2015
Messages
1,806
Reaction score
335
Location
Rochester, New York
usually it is the camera installed off by 180%. I see it all the time and it is easy to do.Looks like a hula dance
 
Joined
Nov 13, 2015
Messages
85
Reaction score
23
Age
30
Joined
Apr 15, 2015
Messages
63
Reaction score
9
Age
39
Thanks guys. Got the motor issues fixed but there seems to be another issue. I cannot swith out of still image mode and into video mode. Whenever I attempt to do that or hit record, camera restarts (lose picture, get a "DJI" logo on black screen, then picture comes back up and all camera settings revert to default. Basically have myself an FPV setup with no way to record images whatsoever. :(

Didn't see any obvious physical damage to ribbon or cables. Yaw bar had busted within the camera circuit board housing so wondering if something on board was damaged at that time or ribbon was compromised.
 
Joined
Nov 13, 2015
Messages
85
Reaction score
23
Age
30
Thanks guys. Got the motor issues fixed but there seems to be another issue. I cannot swith out of still image mode and into video mode. Whenever I attempt to do that or hit record, camera restarts (lose picture, get a "DJI" logo on black screen, then picture comes back up and all camera settings revert to default. Basically have myself an FPV setup with no way to record images whatsoever. :(

Didn't see any obvious physical damage to ribbon or cables. Yaw bar had busted within the camera circuit board housing so wondering if something on board was damaged at that time or ribbon was compromised.
Try it without an SD card, or reformat your SD card?
 
Joined
Oct 10, 2014
Messages
1,833
Reaction score
290
very possible it is your main board that it is overheated. is this a P3P or A?
 

New Threads

Forum statistics

Threads
136,170
Messages
1,408,408
Members
99,079
Latest member
aneal321