DJI PHANTOM 2 v3 HD3D Zenmuse Failsafe issue

Joined
Nov 12, 2016
Messages
7
Reaction score
0
Age
50
Hi guys I'm a newbie here.
I have been using a DJI Phantom 2 v3 ZENMUSE H3-3D AXIS GIMBLE for nearly 3 years with out any glitches.
Recently I decided to take the bird out for a run and went through the usual pre flight steps. Calibrated compass etc.
When I initiate flight the Phantom starts and rises as per normal but at any given height between 3m and 10 it auto FAILSAFES and rises to the preset height and lands.
I have tried several different locations and get the same result.
I have FPV fitted and after the initial setup the Bird registers 10 or more GPS locks and says it is in GPS mode but on take off it auto FAILSAFES.
I have had the lid of and checked for possible wiring issues with out any luck.
I thought I would check the RC and recalibrate it using the RC Assistant software, no matter which micro USB cables I have tried the remote doesnt seem to connect.

I hope I am doing this correctly by memory
1. Connect RC to PC via Micro usb cable and turn on RC and it beep beep beeps and then my PC makes the usual "connected" sound so it appears the PC has recognised the RC
2. Open up the DJI RC assistant software and wait.
No lights appear (green and blue from memory) at bottom left hand side of software window which would normally inicate a connection.

If I connect the Phantom 2 via the USB cable and open up the Phantom 2 Assistant software my RC is recognised and I can calibrate it through the BASIC TAB options. So it appears tht there is a pairing between the Bird and RC.

I am out of ideas and have searched the WEB intensly to try and find other users that may have encountered a similiar problem but with NO LUCK.

Could it be a faulty RC? If so what RC's are compatable for me to purchase and PAIR without outlaying too many $$$ because if the BIRD has an issue than I would have just wasted more coin on a second RC.

Could it be a Compass error on the bird?

In the past I had broken the flimsy RIBBON CABLE connecting the GoPro to the Zenmuse body and this caused the BIRD to RETURN HOME before I picked up on the issue. But the RIBBON CABLE appears to be all intact and servicable?

HELP HELP HELP


Sent from my SM-G920I using PhantomPilots mobile app
 
Joined
Oct 12, 2014
Messages
5,168
Reaction score
577
Location
Commerce Twp,MI
Hi guys I'm a newbie here.
I have been using a DJI Phantom 2 v3 ZENMUSE H3-3D AXIS GIMBLE for nearly 3 years with out any glitches.
Recently I decided to take the bird out for a run and went through the usual pre flight steps. Calibrated compass etc.
When I initiate flight the Phantom starts and rises as per normal but at any given height between 3m and 10 it auto FAILSAFES and rises to the preset height and lands.
I have tried several different locations and get the same result.
I have FPV fitted and after the initial setup the Bird registers 10 or more GPS locks and says it is in GPS mode but on take off it auto FAILSAFES.
I have had the lid of and checked for possible wiring issues with out any luck.
I thought I would check the RC and recalibrate it using the RC Assistant software, no matter which micro USB cables I have tried the remote doesnt seem to connect.

I hope I am doing this correctly by memory
1. Connect RC to PC via Micro usb cable and turn on RC and it beep beep beeps and then my PC makes the usual "connected" sound so it appears the PC has recognised the RC
2. Open up the DJI RC assistant software and wait.
No lights appear (green and blue from memory) at bottom left hand side of software window which would normally inicate a connection.

If I connect the Phantom 2 via the USB cable and open up the Phantom 2 Assistant software my RC is recognised and I can calibrate it through the BASIC TAB options. So it appears tht there is a pairing between the Bird and RC.

I am out of ideas and have searched the WEB intensly to try and find other users that may have encountered a similiar problem but with NO LUCK.

Could it be a faulty RC? If so what RC's are compatable for me to purchase and PAIR without outlaying too many $$$ because if the BIRD has an issue than I would have just wasted more coin on a second RC.

Could it be a Compass error on the bird?

In the past I had broken the flimsy RIBBON CABLE connecting the GoPro to the Zenmuse body and this caused the BIRD to RETURN HOME before I picked up on the issue. But the RIBBON CABLE appears to be all intact and servicable?

HELP HELP HELP


Sent from my SM-G920I using PhantomPilots mobile app
Connect the P2 to the software and check your batteries current levels of fully charged batteries. Also check to see if the critical low battery box has been checked.that act the same way as failsafe when the batteries haven't been stored correctly.
 
  • Like
Reactions: DJIDamo
Joined
Nov 12, 2016
Messages
7
Reaction score
0
Age
50
So should I uncheck the critical battery level box? The bird and remote constantly un pair nearly every time I start the 2 together. RC first then Phantom as per normal procedure.
 
Joined
Nov 12, 2016
Messages
7
Reaction score
0
Age
50
My drone is a Phantom 2 v3 with zenmuse h3-3d gimble and the standard contoller. I do run FPV with a Immersion RC 5.8 GHz 600Mw TX transmitter and 5.8 GHz 7" Diversity screen LCD+DVR with a DJI mini iOSD in Naza mode.
Have used it for a couple of years with no problems. Traveled recently to Indonesia with no glitches but on return there seems to be this persistent "failsafe" on lift off. Having said that the other day ZI had 3 - 4 minutes of non error flying but on landing and take off the next time on same battery the bird did the usual "failsafe at approx 3 m.
I am running windows 10 but have also tried to calibrate the RC directly on a Windows Vista platform with no luck. The PC seems to recognise that the RC is connected but the RC assistant software refuses to recognise it I have even tried running the exe as an "administrator" but this makes no difference. When I connect the Phantom directly and turn on the RC which is 1m away it sometimes is un paired so I reset it and the Phantom holds a green light below and I am able to calibrate through the Phantom vision 3.8 app and all seems fine.
For clarification I have carried out "Compass calibration" before flight at several different loaction and occassions.

The problem could well be the Pairing between [email protected] and RC as I constantly have to reset the [email protected] to pair with RC nearly on every start up!!

I am absolutely baffled.
 
Joined
Nov 12, 2016
Messages
7
Reaction score
0
Age
50
Hi all, I think I have determined that I am breaking connection between the P2 and the remote control. After or during the P2 initial start up procedure the link un pairs between the 2. I reset via the red light switch underneath the P2 and it seems to repair but it only last a seconds or at best 1 minute before the 2 disconnect?

HELP NEEDED

Should I buy another remote or could it be something inside the P2?
 

New Threads

Members online

Forum statistics

Threads
139,535
Messages
1,439,514
Members
101,331
Latest member
bryan.hivemapper