Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Standard Dji go not compatible with your device

Discussion in 'Phantom 3 Help' started by igoinn, Sep 20, 2015.

  1. igoinn

    Joined:
    Sep 20, 2015
    Messages:
    2
    Likes Received:
    0
    Just bought and received my p3s. after trying to download Dji go got the message "not compatible with your device" is there another app I can use for fpv
    Thank you
    Henry.
     
  2. robsquad

    Joined:
    Dec 4, 2014
    Messages:
    962
    Likes Received:
    424
    Location:
    Wolverhampton, UK
    is you device in the compatible list ?
     
  3. igoinn

    Joined:
    Sep 20, 2015
    Messages:
    2
    Likes Received:
    0
    My fault did not check, it before I bought it.
     
  4. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    25,628
    Likes Received:
    7,777
    Location:
    Harrisburg, PA (US)
Loading...
Similar Threads - Dji compatible device Forum Date
Professional just bought p3 dji go app says its not compatible with device I am using iPad 8.4.1 Phantom 3 Help Aug 28, 2015
DJI Compatible 5.8ghz RC Repeater/Controller Device General Discussion May 25, 2015
Ipad air 2 not compatible with DJI go 4 App Phantom 4 Pro Discussion Jun 8, 2017
Dji 4 App 'not compatible' with my iPad Mini or iPhone 5? Phantom 4 Help Feb 8, 2017
Is the DJI Go App 4 compatible with the P3 ? Pro/Adv Discussion Dec 11, 2016