Crazy dance and no image

Joined
Sep 7, 2022
Messages
4
Reaction score
1
Age
27
I made a hard landing a few weeks ago.
The camera then tilted like 5 degrees to the right but worked pretty good.

Then like 1.5 half week later, the gimbal want crazy for 10 seconds and then disconnected.
But after a few seconds i got connected again and it all worked good.

So i flew a few days after again but now the gimbal did the same thing but like 3-4 times during flight.

The start up got really bad were the gimbal just went crazy and spinning around for up to 1 min. I could still fly it but it just kept doing that gimbal spin and then disconnected.
That became so bad that i didnt want to fly it anymore.

I looked at this video to maybee fix the problem:

Both the "screw" and the camera is tilted. Its not like the camera is tilted and the other thing is leveld so im not sure its a problem.

Printscreen from my phone showing the error in the app:
Here are some videos of my drone.
1. Start up, the gimbal going crazy:

2. The gimbal is completely dead. No connection at all. No image or cant steer the camera:


3. When i shut it of, it blinks a red light on the battery. This have never happened before. It should just turn off emidetly: shut down phantom 3 standard

I dont get any image connection at all but the remote connects sometimes only for a few seconds and then disconnect.
Please help.
 
  • Like
Reactions: colo pilot

Capt KO

Capt KO
Joined
Feb 13, 2019
Messages
2,787
Reaction score
2,311
Age
71
Location
IRB, Fl
Loose or disconnected gimble/camera ribbon cables from hard landing. Replug and try again.
 
Joined
Sep 7, 2022
Messages
4
Reaction score
1
Age
27
Loose or disconnected gimble/camera ribbon cables from hard landing. Replug and try again.
I did but i did not make any difference. It goes from good signal/ready to fly, to disconnect or weak signal.
 

Capt KO

Capt KO
Joined
Feb 13, 2019
Messages
2,787
Reaction score
2,311
Age
71
Location
IRB, Fl
In the pics I can see the shaft going into your esc board is no longer aligned with the camera body. From hard landing but easy diy crazy gimble fix.

Looking for simple solutions first. GL
 
Last edited:
  • Like
Reactions: Cecil

Capt KO

Capt KO
Joined
Feb 13, 2019
Messages
2,787
Reaction score
2,311
Age
71
Location
IRB, Fl
Still might need a new OEM ribbon cable for connection issues, $20 eBay. Even if not visible, very thin wires inside can fail quite easily.
Aftermarket suck so make sure package states DJI..not just for dji.
 
Joined
Sep 7, 2022
Messages
4
Reaction score
1
Age
27
In the pics I can see the shaft going into your esc board is no longer aligned with the camera body. From hard landing but easy diy crazy gimble fix.

Looking for simple solutions first. GL
I cant see anything wrong. The camera and the shaft is tilted the same.
 

Members online

Forum statistics

Threads
142,318
Messages
1,462,094
Members
104,082
Latest member
DarioP3S