Standard Can't link RC with controllet

Joined
Jul 7, 2019
Messages
1
Reaction score
0
Age
21
Hi,

I reset my controller frequency by switching the s2 button back and forth. Now I cannot get my rc(P3 model: w321) to pair with my remote.

In trying to push the linking button, I believe it broke and became jammed under the housing. (Picture attached)

It seems to me this was more of an led than a linking button.

I need help understanding how to diagnose it from here. Thank you in advance.
 

Attachments

Oso

Premium Pilot
Joined
May 19, 2015
Messages
4,635
Reaction score
3,559
Location
Western US
Hi,

I reset my controller frequency by switching the s2 button back and forth. Now I cannot get my rc(P3 model: w321) to pair with my remote.

In trying to push the linking button, I believe it broke and became jammed under the housing. (Picture attached)

It seems to me this was more of an led than a linking button.

I need help understanding how to diagnose it from here. Thank you in advance.
Welcome to the forum.

I agree that it looks as if the clear plastic lens has become dislodged and has jammed under the shell.

FYI that it has proven too common over the years for the P3S link switch to completely detach from the main board. Sometimes people can hear it rattling around inside the shell.

If it were mine, I would open the shell to see what happened inside and if the switch itself is still attached. If it were still attached, I’d assess whether or not I’d try to fix the lens or just put it back together without the lens and activate the link switch with a toothpick or something similar.
 

New Threads

Members online

Forum statistics

Threads
138,563
Messages
1,430,737
Members
100,574
Latest member
Paul308GTSi