Cannot bind RE > drone, no LED on camera.

Joined
Jul 6, 2019
Messages
3
Reaction score
0
Age
59
Hi all!
A friend of mine got himself a Phantom 4, and so he gave me his old Phantom 2 Vision +!
He told me it crashed into some trees during a RTH procedure, and had not flown since.
When powering up most seems ok. Remote is bound and working, motors spinning and gimbal is working too.
But there is no LED on the camera/gimbal board. First time I tried it range extender and drone seemed to be bound together, but the app said "no SD card" and I had no telemetry data and no LED on camera.
I tried to rebind, and have gone through that procedure like ten times... won't work. Scanned the code, entered mac address manually... doesn't work. If I scan my wifi network I can see there is a device (hidden) with that mac address, but still can not bind.

Apparently camera is dead for some reason, but why this binding issue? I've tried both on my Android and my iPhone.

Thanks for reading this rather lengthy message...
 
Joined
Oct 31, 2014
Messages
1,980
Reaction score
343
Age
49
Location
Manchester UK
Hi all!
A friend of mine got himself a Phantom 4, and so he gave me his old Phantom 2 Vision +!
He told me it crashed into some trees during a RTH procedure, and had not flown since.
When powering up most seems ok. Remote is bound and working, motors spinning and gimbal is working too.
But there is no LED on the camera/gimbal board. First time I tried it range extender and drone seemed to be bound together, but the app said "no SD card" and I had no telemetry data and no LED on camera.
I tried to rebind, and have gone through that procedure like ten times... won't work. Scanned the code, entered mac address manually... doesn't work. If I scan my wifi network I can see there is a device (hidden) with that mac address, but still can not bind.

Apparently camera is dead for some reason, but why this binding issue? I've tried both on my Android and my iPhone.

Thanks for reading this rather lengthy message...

No light means the camera is busted, you wont be able to get a successul binding as it needs the camera active, however it could be something simple such as a loose wire, does the camera hang limp or does it power on and go level (or slightly pointed down on the V1)
 
Joined
Jul 6, 2019
Messages
3
Reaction score
0
Age
59
Well I took the whole assembly apart. As you can see from the attached picture, the crash might have damaged the board. When I had it assembled again I connected a USB cable from the board to my laptop, but it didn’t show up as a drive. But now when I powered up the machine I got a blinking red LED on the board, that after ~30 seconds turns a solid red...
I then took out the SD card and formatted it. Put it back and powered up, and got a green! LED for a few seconds, then turned red.
Tried binding again, this time on my iPad, and it seemed to work as it showed the right mac address in the binding dialog. But still it says connection broken.
The camera/gimbal powers up and goes level, then tilts down like 45 degrees.
 

Attachments

Joined
Jul 6, 2019
Messages
3
Reaction score
0
Age
59
No light means the camera is busted, you wont be able to get a successul binding as it needs the camera active, however it could be something simple such as a loose wire, does the camera hang limp or does it power on and go level (or slightly pointed down on the V1)
Well, I took it all apart. Lifted the top cover off the aircraft too. I can't find any loose cables or connectors.
Now it says "camera bound", but still broken connection and sometimes "no SD card".
Do you think it's worth trying a replacement board (gimbal/camera) from eBay?

Thank you,
Pär
 
Joined
Oct 31, 2014
Messages
1,980
Reaction score
343
Age
49
Location
Manchester UK
Well, I took it all apart. Lifted the top cover off the aircraft too. I can't find any loose cables or connectors.
Now it says "camera bound", but still broken connection and sometimes "no SD card".
Do you think it's worth trying a replacement board (gimbal/camera) from eBay?

Thank you,
Pär
it depends on the cost, sometimes you just have to let go and giveup, the boards are hard to find anywhere, might be better to find a new camera unit
 

New Threads

Forum statistics

Threads
136,126
Messages
1,407,884
Members
99,052
Latest member
Wimpiri