Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Camera firmware issues....

Discussion in 'Firmware' started by robb01, Feb 2, 2015.

  1. robb01

    Joined:
    Nov 30, 2014
    Messages:
    37
    Likes Received:
    8
    What am I doing wrong???? I downloaded 1.3 from the site, inserted a fresh sd card into my Phantom, formatted it, turned off the phantom and then put the 1.3 on the SD card, renamed it firmware_plus.bin, put it in the Phantom, powered on, the camera light blinked red 3 times quickly and then went to green, on the app it still shows the old fir ware version

    Tried it again and this time the camera led blinked red for about 10 seconds, blinked green once and them kept blinking red.....

    Powered off, tried 3 different cards and never could get the new fir ware loaded....Any tips?
     
  2. crash1sttime

    Joined:
    Oct 31, 2014
    Messages:
    1,438
    Likes Received:
    185
    Location:
    Manchester UK
    Have you tried using the original SD card, I've heard that other cards cause problems
     
Loading...
Similar Threads - Camera firmware issues Forum Date
Camera issues after 1.06.0040 firmware update Pro/Adv Discussion Dec 28, 2015
P4P Camera Sensor Error after firmware update Phantom 4 Pro Help Aug 13, 2017
P4 Camera broke lose in mid-flight, firmware or hardware problem? Phantom 4 Discussion Apr 17, 2017
Standard Firmware Update camera seizure Phantom 3 Help Feb 18, 2017
Professional Firmware update failed, can't see live camera feed Phantom 3 Help Jan 10, 2017