Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Binding Problem: New camera MAC address?

Discussion in 'Phantom 2 Vision + Help' started by MartinBernstein, Jul 4, 2015.

  1. MartinBernstein

    Jul 4, 2015
    Likes Received:
    Thanks in advance for help.

    The problem is that I cannot bind my camera to the app so I cannot see what the camera sees. Everything else appears to work normally- the drone itself, the controller, the range extender and the camera. But when I try to use the camera i cannot see anything. See screenshots.


    September 2014: I sent everything in to DJI for repair for unrelated issue. They replaced camera and gimbal assembly with new one.

    October: I received drone with new camera. Everything worked as it was supposed to. No binding necessary.

    April 2015: After winter storage I tried to fly but encountered the above stated problem- no connection to new camera. The app requires me to bind to new camera and asks for MAC address (see screenshots). After researching online forums I still have no idea how to find the new camera's MAC address. I use an iPhone and iPad.

    Anyone have similar problem? Any solutions?

    Attached Files:

  2. jcknows0

    Dec 21, 2014
    Likes Received:
    Northern NJ
    That definitely sounds like an error. However, you can easily find out the MAC address connecting to the wifi module (with computer) and try pinging the network. Its probably written on the unit somewhere as well or on a tag (I confess I had only a little exposure to P2V platform)
  3. markn

    Apr 30, 2014
    Likes Received:
    Sounds like you may be having the same problem as I did and others have shared - http://www.phantompilots.com/threads/binding-or-other-camera-problem-any-help-appreciated.34676/

    In order to rebind, you will need the MAC address, which you can obtain by scanning the QR code off the box the Phantom was shipped in or calling DJI. The app I used to scan the QR code did not work but too me to a very long hyperlink. The last set on numbers and characters in the hyperlink is the MAC address. The first six of which will be on the app when you go to rebind.
Similar Threads - Binding Problem camera Forum Date
Binding or other camera problem any help appreciated. Phantom 2 Vision + Discussion Feb 7, 2015
Problem Binding with the FC 200 Camera Phantom 2 Vision Discussion Aug 23, 2014
New Camera Binding Problem Phantom 2 Vision Discussion Apr 2, 2014
Un-binding rc or something else the problem? Pro/Adv Discussion Dec 12, 2016
Wifi problem after binding Phantom 2 Vision Help Feb 4, 2016