Annoying lag after pressing shutter button

RPP

Joined
Jul 29, 2016
Messages
249
Reaction score
109
Location
Iceland
I use an iPad mini with my P4P v2 controller. When I take a photo using the controller button, there is a lag before it is ready for the next exposure. In the interim the red button on the iPad keeps ‘rotating’ before it is ready for the next shot.

Anyone else experiencing this?

(My iPad software and DJI Go app are all updated to the latest versions, as is the drone firmware.)
 

RPP

Joined
Jul 29, 2016
Messages
249
Reaction score
109
Location
Iceland
I see this issue has been around for a while -

 

JeffreyS

Premium Pilot
Joined
Nov 23, 2018
Messages
625
Reaction score
668
Not really an 'issue', but rather simply the time it takes to write the file to the card. Could be a slow card, but the Phantom's do not have large buffers to make quick shooting easy. I've pressed the shutter again while a file is being written and I believe it also gets written to the card in order. What I don't like is that I don't hear the pretend shutter sound on any exposures while writing is in process. Very unsettling. This is a flaw in the software.
 
  • Like
Reactions: RPP and Capt KO
Joined
Apr 10, 2015
Messages
147
Reaction score
67
I use an iPad mini with my P4P v2 controller. When I take a photo using the controller button, there is a lag before it is ready for the next exposure. In the interim the red button on the iPad keeps ‘rotating’ before it is ready for the next shot.

Anyone else experiencing this?

(My iPad software and DJI Go app are all updated to the latest versions, as is the drone firmware.)
Yes...I have it too. Seems it takes some time to write the photo to the card. Photos are fine, just can't shoot rapid fire.
 
Joined
Feb 9, 2015
Messages
558
Reaction score
226
Location
Herefordshire
There is a useful hardware test program on PC called h2testw, it can reveal the r/w speeds of USB memory sticks and cards (and can also be used to test the entire card)

I have often found (with video cameras and DSLR) that SD cards that have been used for a while can 'hit the wall' and start to degrade on speed.

I use only use Sandisk Extreme Pro cards with my P4Pro.

HTH
 
Joined
Aug 7, 2016
Messages
905
Reaction score
502
SanDisc Extreme/ PRO !
This should work with no issues.
 
Joined
Jan 26, 2019
Messages
39
Reaction score
15
In my case P4P pressing the shutter button on the controller will make a shutter sound but only once every three pictures ! But the photos will be taken even without earring he sound !
 
  • Like
Reactions: JeffreyS
Joined
Jan 26, 2020
Messages
5
Reaction score
1
Age
54
Have the same issue when doing inspections and having to wait to take the next photo, running the fastest available SD cards. Annoying
 
  • Like
Reactions: RPP
Joined
Feb 9, 2015
Messages
558
Reaction score
226
Location
Herefordshire
So the next thing I'd try is set the photo mode to JPEG, not JPEG+RAW (this might demonstrate that it's a write speed issue)

I'm guessing that you're definitely in single shot mode, not bracketing, etc?

A
 

RPP

Joined
Jul 29, 2016
Messages
249
Reaction score
109
Location
Iceland
So the next thing I'd try is set the photo mode to JPEG, not JPEG+RAW (this might demonstrate that it's a write speed issue)

I'm guessing that you're definitely in single shot mode, not bracketing, etc?

A

I shoot in RAW (not RAW+JPEG). And yes, single node. DJI can't handle writing sufficiently fast to the top of the line SanDisk cards?
 

New Threads

Forum statistics

Threads
138,994
Messages
1,434,625
Members
100,935
Latest member
kosmo_gizmo