What caused my crash and how do I fix it.

Joined
Mar 9, 2020
Messages
1
Reaction score
0
Age
41
Hey guys. I have a p2v+ v2 bought it used. I have been flying it for about 3 months now with no problems. It has a new gps module as well. The flight was 13c 6kph winds and in a area with no sources of interference. On the weekend we took it out lifted off to about 10 feet hovered for a moment (in gps mode 11 satalites) I started flying out into the field she jerked in the air and started comming back towards me at full speed. I switched to atti and attempted to get control again. Managed to turn her back towards me but about 200 feet to my left. I got it to hover and attempted to land pulling the stick down she started to descend then jumped forward did a flip leveled out kept moving forward while pitching the nose down and well she landed ... Split the ribbon cable on the camera and bent the arm I have a spare camera so that's not a worry. I have pulled everything apart found a couple small cracks in the shell checked my connections reset the imu and fired her up without props. Everything sounds fine but once I attempted another flight she gets up starts to tip and comes back down. The motors sound like they are out of sync or something if I leave it running on the table one will speed up then another and so on. Hope I can save her
 

Attachments

  • IMG_20200307_130037.jpg
    IMG_20200307_130037.jpg
    6.4 MB · Views: 84
Joined
Oct 31, 2014
Messages
2,227
Reaction score
429
Age
50
Location
Manchester UK
Hey guys. I have a p2v+ v2 bought it used. I have been flying it for about 3 months now with no problems. It has a new gps module as well. The flight was 13c 6kph winds and in a area with no sources of interference. On the weekend we took it out lifted off to about 10 feet hovered for a moment (in gps mode 11 satalites) I started flying out into the field she jerked in the air and started comming back towards me at full speed. I switched to atti and attempted to get control again. Managed to turn her back towards me but about 200 feet to my left. I got it to hover and attempted to land pulling the stick down she started to descend then jumped forward did a flip leveled out kept moving forward while pitching the nose down and well she landed ... Split the ribbon cable on the camera and bent the arm I have a spare camera so that's not a worry. I have pulled everything apart found a couple small cracks in the shell checked my connections reset the imu and fired her up without props. Everything sounds fine but once I attempted another flight she gets up starts to tip and comes back down. The motors sound like they are out of sync or something if I leave it running on the table one will speed up then another and so on. Hope I can save her

Sounds like a calibration issue, Try a full IMU calibration and then do a compass calibration, heck I would even do the full remote control calibration whilst you are at it
 

New Threads

Forum statistics

Threads
140,485
Messages
1,448,118
Members
102,280
Latest member
Rural Rider