Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

unable to start the motors manually by sticks (Phantom 3 standard)

Discussion in 'Standard/4k Discussion' started by a4almalki, Jul 23, 2016.

  1. Did you get any factory defects in remote control ?

    0 vote(s)
  2. remote control for Phantom 3 standard

    0 vote(s)
Multiple votes are allowed.
  1. a4almalki

    Jul 19, 2016
    Likes Received:
    Hi there ,
    I am now here : )
    I have had my Phantom 3 standard for 6 days . but I have problem that I am unable to start the motors manually by two sticks
    after that I use Auto takeoff , it was worked but I could not control my aircraft there was no action by sticks ( up ,down ,left , right ) on both sticks , Next I have tried to re calibrating the remote control I noted that when
    I put sticks to centre
    all percentage of ranges is 0 % only the up left is 51% ,I am not sure is that normal .
    and when i move the left stick left and down percentage down is 0% and left 100% !!!
    is it mean the down one not work fine ?!!

    I hope some one help me on that

    Attached Files:

  2. Mark The Droner

    Aug 26, 2015
    Likes Received:
    Sounds like you have a bad controller. I would open it up and take a look or return it.
    a4almalki likes this.
Similar Threads - unable start motors Forum Date
I have had My Phantom 3 adv for a week. Unable to start motors manually. Any ideas ? Phantom 3 Help Jan 29, 2016
Standard Unable to get Litchi to start Phantom 3 Help Jul 14, 2017
Unable to start & view through app Phantom 2 Help Jul 24, 2016
Unable to start the motor with CSC Phantom 3 Help Nov 23, 2015
Unable to start the P3A with CSC Pro/Adv Discussion Nov 23, 2015