Unable to link remote control and aircraft

Joined
Apr 15, 2015
Messages
26
Reaction score
7
Location
Los Angeles
My Phantom 2 and remote control lost link during flight and returned home. I've connected the RC to PhantomRC and did a calibration and all was fine. When I open up the Phantom application with both Phantom and RC connected via USB I am unable to see stick, gimbal, S1 or S2 movement under <Basic> <RC> tab, as if a remotes not even connected. I've tried resetting controller on Phantom by holding link button until flashing red appears, and reinstalling the firmware in PhantomRC has had no affect whatsoever on the outcome.
 
Joined
Sep 12, 2014
Messages
3,470
Reaction score
945
Location
Where the deer and the antelope play
Joined
Jun 16, 2015
Messages
10
Reaction score
0
Location
Kanata
Hey Josh,
I was having the same issues, was the bad controller the result of a crash? I've just sent mine off so I'm hoping its the same issue and mine will be returned back to me.
 
Joined
Apr 15, 2015
Messages
26
Reaction score
7
Location
Los Angeles
Rob, no, it was due to an error that occurred during a firmware update. The controller on the P2 didn't accept the update and went bad.
 
Joined
Jun 16, 2015
Messages
10
Reaction score
0
Location
Kanata
That seems very positive for me then. Mine stopped working immediately after doing the update. My P2 has only been gone about 5 days and I already wish it was back.
How long did it take to get yours back, was it the full 6 weeks?
 
Joined
Apr 15, 2015
Messages
26
Reaction score
7
Location
Los Angeles
It was the full 6 weeks and if I hadn't of called at the end of the six weeks it quite possibly would have been an additional 3. They tried to tell me it wasn't 6 weeks from time I shipped but a full 6 weeks from time they actually document it as received which was several weeks after it actually was delivered.
 
Joined
Jun 16, 2015
Messages
10
Reaction score
0
Location
Kanata
Well its been over a week since I've sent it, its still not showing as "Received" through USPS. Thought I would call and see if there was anyone that could tell me it was received or not. "Please call back in 2-3 weeks and we will be able to tell you". Great. Really regretting sending it away already. I Didn't check the GPS module to see if it was cracked but that's what I'm betting on right now.
 

New Threads

Forum statistics

Threads
134,106
Messages
1,387,966
Members
97,789
Latest member
AntDX316