Tried to update transmitter software and now it is dead

Joined
May 26, 2015
Messages
3
Reaction score
0
Age
66
I had not flown my Phantom 2 in a while and decided to update all of the firmware. When I connected my transmitter (model DJ6) and started the update, the LED on the transmitter went out and I got a message that the update had failed. Now the transmitter is still dead.

Has anyone seen this???
 
Joined
Apr 10, 2014
Messages
2,278
Reaction score
1,251
Age
49
Location
Sarasota, FL. USA!
It has been happening a lot lately, just reconnect, and reinstall firmware!
Your update got corrupted somehow, try again, should be ok!

J Dot

Keep us informed!
 
Joined
May 26, 2015
Messages
3
Reaction score
0
Age
66
It has been happening a lot lately, just reconnect, and reinstall firmware!
Your update got corrupted somehow, try again, should be ok!

J Dot

Keep us informed!
The transmitter seems to be dead, I have taken the batteries out and no power LED, also when I start the RC Phantom, it doesn't recognize it.
 
Joined
Apr 10, 2014
Messages
2,278
Reaction score
1,251
Age
49
Location
Sarasota, FL. USA!
Did you hook to RC assistant, and reinstall firmware? The same thing happened to a couple pilots here, turn button on, and nothing, no lights, no beep beep, ect! They plugged into RC assistant reinstalled, and beep beep, lights on, also make sure batteries installed correctly, might want to open it, to make sure nothing came loose!

Keep us updated!

J Dot
 
Joined
May 26, 2015
Messages
3
Reaction score
0
Age
66
Did you hook to RC assistant, and reinstall firmware? The same thing happened to a couple pilots here, turn button on, and nothing, no lights, no beep beep, ect! They plugged into RC assistant reinstalled, and beep beep, lights on, also make sure batteries installed correctly, might want to open it, to make sure nothing came loose!

Keep us updated!

J Dot
I changed the batteries and nothing happened, then I notice I had one of them in backwards. I fixed that, started RC assistant, plugged it in and bingo it connected, updated and seems to be working normally.

Thanks for your help!!!
 

New Threads

Members online

Forum statistics

Threads
141,065
Messages
1,452,868
Members
102,888
Latest member
sonu9180