Take off Anomaly

Joined
Jun 5, 2015
Messages
12
Reaction score
4
Age
50
So I updated all firmware on my P3P, and have made several short flights without issues over several days and numerous locations. Tonight at new location took off and hovered at around 10 feet and craft is not wanting to stay put but is wandering around a 3-4 ft circle. It wasn't losing or gaining altitude but definitely not acting normal. I increased altitude another foot or so and then rock solid. Flew close and low for a few minutes and all perfect. Entire flight flawless from then on, including Hovering at 2 ft for a little bit. For the record - vps off. 15 + GPS sats. Calibrated compass in open field no metal . So is this normal behavior (The wandering?)
 

msinger

Approved Vendor
Joined
Oct 30, 2014
Messages
31,306
Reaction score
10,445
Location
Harrisburg, PA (US)
Website
PhantomHelp.com
Try toggling the VPS on and back off. I haven't seen this issue myself, but someone on the DJI forum reported it was turned on even though the setting was set to off.
 
Joined
Oct 20, 2014
Messages
498
Reaction score
238
Location
Alberta, Canada
I do get this sometimes. Pretty similar - immediately after takeoff, hovering at 4-6 feet, and I always have a need to correct it. After ascending to 20-30 feet it stabilizes and is fine for the rest of the flight, also down low near the ground (2-3 feet and when landing). Almost like the compass if confused at first. I am used to it and it doesn't bother me.
 
Joined
Oct 20, 2014
Messages
498
Reaction score
238
Location
Alberta, Canada
Here is my weird thing - first 2-3 flights out of the box, auto takeoff would hover around 4-5 feet. Now, with zero firmware updates, it always hovers at about 2 feet. Also, in used to it and throttle up right away.
 
Joined
Mar 13, 2015
Messages
1,064
Reaction score
309
My P3P started doing something similar tonight, latest firmware was installed beforehand with a cold IMU and gimbal calibration followed by a compass calibration in the field just before flight.

VPS on and it was moving around all over when low, side to side and up and down maybe a few feet, there was no wind and 18 satellites.

I turned off VPS while in flight then landed and power cycles everything, craft and controller and took off again to see.

This time with VPS the P3 below ~20ft wanted to slowly move up until about 20ft. My altitude figures were crazy. At actual 20ft up it showed 0ft and at actual 1ft off the ground it was negative 22ft or so. Very weird. Not sure what to do. But, the latest firmware seemed to have greatly improved the unlevel gimbal horizon issue I was having.
 

New Threads

Forum statistics

Threads
139,786
Messages
1,441,909
Members
101,514
Latest member
Alcudia60