Strong Interference Warnings

Joined
Sep 2, 2021
Messages
51
Reaction score
21
Age
66
Location
Prescott, AZ
I still get the "Strong Interference" and "Strong WiFi interference" warnings popping up, even when flying nowhere near any power lines, etc. Not sure why. I have my iPhone 11 on Airplane Mode and its Bluetooth turned off; the only thing that's running is its WiFi, connected to the P3S.
Any ideas as to:
a. what's causing it and
b. how can I correct/disable/get rid of it?
I normally just ignore them, but it does bother me when I see them popping up.
 
Last edited:
Joined
Feb 13, 2015
Messages
1,120
Reaction score
243
Age
66
Location
SoCal, USA
Did you try to switch frequencies?
 

Meta4

Moderator
Staff Member
Premium Pilot
Joined
Jan 8, 2014
Messages
14,936
Reaction score
8,945
Any ideas as to:
a. what's causing it and
b. how can I correct/disable/get rid of it?
It's common and normal to have wifi interference if you are flying in urban residential or commercial areas.
It's coming from homes and businesses, not power lines.
 
Joined
Oct 16, 2017
Messages
3
Reaction score
1
Age
55
I have the same, flying with Litchi and Phantom 3S. I also ignore the warnings when they are unexpected. Those warnings came up after an update, before, there were no warnings. So I think that the warnings are a bug and not a real danger.
 
  • Like
Reactions: Billie Nelson
Joined
Sep 2, 2021
Messages
51
Reaction score
21
Age
66
Location
Prescott, AZ
I have the same, flying with Litchi and Phantom 3S. I also ignore the warnings when they are unexpected. Those warnings came up after an update, before, there were no warnings. So I think that the warnings are a bug and not a real danger.
However, even when I was flying out "in the boondocks", about 30 miles (Chino Valley, AZ) north of here, nowhere near any homes or businesses (or power lines), I was still getting them popping up every few seconds or so, sometimes in rapid succession.
 
Last edited:
Joined
Aug 7, 2016
Messages
1,292
Reaction score
774
I'm more worried when such warnings appear at or before taking off. Changing the take-off place usually helps.
And don't forget to switch your mobile to the flight mode when flying a drone. Often people forget this.
 
Joined
Aug 17, 2020
Messages
225
Reaction score
140
Age
36
I have the same, flying with Litchi and Phantom 3S. I also ignore the warnings when they are unexpected. Those warnings came up after an update, before, there were no warnings. So I think that the warnings are a bug and not a real danger.
For some odd reason, this observation reminds me of the advice given to me by a college professor many moons ago: " Whenever you sense a train of thought materializing in your brain, lie down quietly and try to relax until it goes away."

Apologies for this minor digression. Normal transmission may now resume.
 
Joined
Aug 7, 2016
Messages
1,292
Reaction score
774
The interference can be sometimes solved by switching from 2.8MHz to 5.6MHz. This is a standard option in Phantom and in Mavics as well I believe. Usually 2.8 gets more interference. You can do it during the flight or set it as auto switch if one band has issues. But I'm not sure if this 'auto' really works.
 

New Threads

Members online

No members online now.

Forum statistics

Threads
141,292
Messages
1,454,656
Members
103,096
Latest member
Eagle928