Sparkle in Video (Compression problem?) NOW WITH PHOTOS! Best settings to avoid?

Joined
May 25, 2016
Messages
241
Reaction score
94
Age
58
Shooting lately I noticed that there is "sparkle" in some of the shots, in the dark areas near high contrast.

A short video example of the problem down sampled to 1080
View or download

The shots I am showing below: settings were: 4K 30p shutter 60, D-Log style settings @ -2/-1/-1 using a ND 16 in full sun. Some stills, the white spots change positions through the video and sometimes not there at all:
CLICK THE IMAGE TO SEE FULL SIZE
4K_White_Dot_Example_DJI_P4_001.jpg


4K_White_Dot_Example_DJI_P4_002.jpg


4K_White_Dot_Example_DJI_P4_003.jpg



The frames of the pier were taken from video you can see below
you can download here it's big 142MB (on this page click the arrow next to "download" and choose "direct download" to get the full 4K video as you will not be able to see the problem in the streaming video):

Dropbox - 4K_White_Dot_Example_DJI_P4.mp4

The white spots are about 1 pixel wide and maybe 2 -6 pixels high, you can see them in the red highlighted areas around the bottom of the pylons.

Since then I have done some testing with the settings and even at -3/-3/-1 there is still a limited amount of this.
Strangely when turned up to +2/+2/-1 it is less noticeable but the video overall looks crappy.

Does anyone notice this in your video, is this normal? I figure it is just because with the mpeg compression and low bandwidth of the camera there are artifacts.

If so what settings can I use to avoid this? Every shot goes through post anyhow but this is a pain to get rid of, I have to use a traveling mask and blur the pixels to get rid of them.

If this is abnormal and I have to send the bird for service I will have some problems as I am traveling to New Zealand in February and need to take it with me, and I know DJI is slow. Also the Phantom 4 is registered with a N number with the FAA for commercial use outside of the USA so I can not accept a refurb as the airframe serial number is tied to the N number.

Any advice is appreciated.

dangerd
 
Last edited:
For anyone who may have this problem in the future, I sent the Phantom to DJI and they replaced the
Phantom 4 camera main board.
Still waiting for the UAV to get shipped back to test, hopefully this solves the problem.
 
For anyone who may have this problem in the future, I sent the Phantom to DJI and they replaced the
Phantom 4 camera main board.
Still waiting for the UAV to get shipped back to test, hopefully this solves the problem.
There is a youtuber named "Ken Heron" who had sparkles really bad on his posted videos. He sent his back to DJI who replaced the camera, but I can't remember now if they did the main board also. Good to hear DJI is coming through for you.
 
The Phantom has returned from DJI and after testing so far so good. They yanked out the main video board and replaced it. Thank you for your responses.
 

Members online

Forum statistics

Threads
143,084
Messages
1,467,515
Members
104,960
Latest member
poojacuisine