RC firmware help please

Joined
Jan 3, 2015
Messages
36
Reaction score
5
Hi guys, just wondering if you can help. Flying my quad today and all was good, brought it in to change the battery, put fresh battery in and then solid red lights showing and would not let me fly. Camera still worked ect. Brought it home and did an update on the quad then went to update the RC through my iPad on the app and where as on some YouTube clips you get the option to download after tapping the icon mine comes up with this.....Current remote controller not support DJI GO firmware update. Download firmware v1.3.20 by using USB at DJI - The Future Of Possible products inspire-1 / downloads. And this was in the bit where everyone seems to be able just to tap the download. Any help much appreciated. Cheers Ian.
 

Attachments

Oso

Premium Pilot
Joined
May 19, 2015
Messages
4,376
Reaction score
3,149
Location
Western US
Hi guys, just wondering if you can help. Flying my quad today and all was good, brought it in to change the battery, put fresh battery in and then solid red lights showing and would not let me fly. Camera still worked ect. Brought it home and did an update on the quad then went to update the RC through my iPad on the app and where as on some YouTube clips you get the option to download after tapping the icon mine comes up with this.....Current remote controller not support DJI GO firmware update. Download firmware v1.3.20 by using USB at DJI - The Future Of Possible products inspire-1 / downloads. And this was in the bit where everyone seems to be able just to tap the download. Any help much appreciated. Cheers Ian.
Do you know what version of the FW is on your RC currently?

If it's too old (pre 1.32) you will need to update it to 1.32 first by using the old original method with a USB card reader inserted into the RC. After you've done that, you should have the ability to do additional updates through the app as you saw on the video.

What FW version did you put on your quad earlier today? Just asking because if you've updated your AC to 1.8 or later, you will need to be at 1.6 or later on your RC.

FYI that this post by @msinger is the go to post for FW updating information.
 
Last edited:
  • Like
Reactions: JoBe
Joined
Jan 3, 2015
Messages
36
Reaction score
5
Do you know what version of the FW is on your RC currently?

If it's too old (pre 1.32) you will need to update it to 1.32 first by using the old original method with a USB card reader inserted into the RC. After you've done that, you should have the ability to do additional updates through the app as you saw on the video.

What FW version did you put on your quad earlier today? Just asking because if you've updated your AC to 1.8 or later, you will need to be at 1.6 or later on your RC.

FYI that this post by @msinger is the go to post for FW updating information.
Thanks Oso have now sorted it after a weekend of going mad. Well chuffed Cheers
 
  • Like
Reactions: Oso

New Threads

Forum statistics

Threads
136,109
Messages
1,407,679
Members
99,043
Latest member
JbroDrone