R/C will not connect to copter.

Joined
Jul 25, 2017
Messages
4
Reaction score
0
Age
25
Last week i purchased a phantom 3 standard on craigslist, and when i bought it the guy selling it couldn't get his phone to connect to it, so there was no video recording capability or anything along those lines. he taught me how to fly it without a phone, but i really want to use the app so i can record video.


After looking into it before purchasing i thought it would be a simple firmware fix, i was wrong. i then thought it was the R/C that was broken when he was installing the range extenders, but the new remote came in today and it still will not work. I have tried all the ways of properly connecting the drone to the controller, but both the light on the bottom and the light on the remote are still solid red.


Please help me figure out this issue, i really do not want to spend anymore money on this drone!!!


P.S. the drone does give off a wifi signal, but when opening the app camera screen all values read "N/A" , it says gimbal disconnected, and no battery levels are detected, basically it's just completely not working.
 
I have tried all the ways of properly connecting the drone to the controller, but both the light on the bottom and the light on the remote are still solid red.
Please explain what were "all the ways" you already tried to relink the AC and the RC.

Are you doing the steps outlined here:
To view this content we will need your consent to set third party cookies.
For more detailed information, see our cookies page.
 
Please explain what were "all the ways" you already tried to relink the AC and the RC.

Are you doing the steps outlined here:
To view this content we will need your consent to set third party cookies.
For more detailed information, see our cookies page.
yes, i tried it with the app & by rotating the gimbal control the left and switching up and down the s2 switch. neither way works.
 
@codychurch2
Welcome to the forum!

Not a good start...

"it says gimbal disconnected, and no battery levels are detected"

I say with no gimbal, you will never get a re-link to a different remote. You won't be able to fly with that remote until you get both green leds.

What is wrong with the gimbal, I won't be any help. If it flew with the original remote, its because it was still linked. No picture and telemetry is a problem with the gimbal, the gimbal sends out these signals (WiFi frequencies on two different channels). The signals go from the gimbal to some kind of circuit board then to the antennas in the landing gear. That signal is sent to the remote, the remote then sends the data WiFi on the channel that you can see on your mobile device.

Unless somebody corrects me, I say your used unit is / was broke. :(

Rod
 
@codychurch2
Welcome to the forum!

Not a good start...

"it says gimbal disconnected, and no battery levels are detected"

I say with no gimbal, you will never get a re-link to a different remote. You won't be able to fly with that remote until you get both green leds.

What is wrong with the gimbal, I won't be any help. If it flew with the original remote, its because it was still linked. No picture and telemetry is a problem with the gimbal, the gimbal sends out these signals (WiFi frequencies on two different channels). The signals go from the gimbal to some kind of circuit board then to the antennas in the landing gear. That signal is sent to the remote, the remote then sends the data WiFi on the channel that you can see on your mobile device.

Unless somebody corrects me, I say your used unit is / was broke. :(

Rod
oh man.. do you think there is a possibility of it just being a broken cable or something like that? broken antenna?
 

Recent Posts

Members online

Forum statistics

Threads
143,021
Messages
1,467,029
Members
104,897
Latest member
TKDroon