question about dji go app

Joined
Oct 18, 2016
Messages
6
Reaction score
0
Age
39
Hey guys I just have bought new phone, the old one is dead.
The new one is xperia xz but it seems dji go app doesnt work with it. do you have any suggestions how can be fixed it, or to lay on the hope that the friends from dji will release soon version which will work with the new hardware?

thanks in advance
 

msinger

Approved Vendor
Joined
Oct 30, 2014
Messages
31,051
Reaction score
10,313
Location
Harrisburg, PA (US)
Rosen, what exactly doesn't seem to be working?
 
Joined
Oct 18, 2016
Messages
6
Reaction score
0
Age
39
The app is working normally, but cannot connect to the P4 and camera mode. The camera mode is in grey and says "how to connect" iso "camera mode"
also I see that the phone does not receive power from the RC - no charging
 

msinger

Approved Vendor
Joined
Oct 30, 2014
Messages
31,051
Reaction score
10,313
Location
Harrisburg, PA (US)
Until DJI starts supporting additional devices, it would be best to stick to the devices on this list.
 
Joined
Oct 18, 2016
Messages
6
Reaction score
0
Age
39
I learn it by the hard way, any way I have got already the new XZ, the old one will be repaired in few days it is Xperia Z which is not listed above, but works nice with the app and P4.
I hope my new device to get in use soon
 
Joined
Jan 3, 2016
Messages
176
Reaction score
42
Age
49
is your new phone running android 6.x? if so thats why.. roll back to android 5.x lollipop and you will be good to go.

Sent from my SM-G935F using PhantomPilots mobile app
 
Joined
Oct 18, 2016
Messages
6
Reaction score
0
Age
39
that is right, it is running android 6.x...it came with it and I am not so good to roll it back to previous version, except with the factory reset option, which will not affect the version in this case.
May be I did not explain well at the beginning. the DJI go app is installing and working on the device, the problem is that the device does not communicate with the RC through the USB it does not receive even charging. it has the new port usb c or something like that
 
Joined
Oct 18, 2016
Messages
6
Reaction score
0
Age
39
Hey guys, I have managed to fix my problem and now officially I can say Xperia XZ is ok to fly with P4
What I did is simple and you all know this.
1. enabled developer mode
2. enabled usb debugging
and
3. I have selected the USB to be used for MTP

All this I have done it before, but with cable connected to the RC and the result was 0.
This time I have tried all the above steps but without to connect the USB cable to my XZ and when all settings has been done I connected the cable to RC and XZ and voala!!! it is working perfectly - for now.
I did a test flight and everything seems to be fine. no app crashing, no lagging.. I hope to continue like this
 
Last edited:
Joined
Jan 29, 2015
Messages
4,851
Reaction score
2,065
Location
Salt Lake City, UT
is your new phone running android 6.x? if so thats why.. roll back to android 5.x lollipop and you will be good to go.
Just as a note, the DJI Go app runs just fine under Android 6.x. There are _many_ people running this OS without any issues. It's not an issue.[/QUOTE]
 
Joined
Oct 18, 2016
Messages
6
Reaction score
0
Age
39
I am stucked again, after few days working fine, the XZ just stop recognize the rc usb again and the strange is that nothing has changed, no updates received during this time (any updates)
Now I am at the beginning again. The phone is still sounding when I am plugging the usb, but not recognize any device, does not receive charging and do not offer the options MTP, charging etc...
In the settings nothing is changes, all settings are like the moment it was working :(
 

New Threads

Forum statistics

Threads
136,140
Messages
1,408,054
Members
99,056
Latest member
giorgioalonso