Advanced Possible fix for RC SIGNAL LOST after 1.8 Update

Joined
Feb 26, 2015
Messages
7
Reaction score
4
Location
High Peak UK
Having a very similar issue to some others on here with my P3A. Upgraded to 1.8 on the aircraft...now getting RC signal Lost on DJI Go App. The symptoms mine was showing are as follows:

- RC SIGNAL LOST on app.
- Log file confirms 1.8 was installed on Aircraft.
- No method will upgrade the RC (GL300C) tried the usb stick, sd and cable method. (since found out only GO app will work on the C model)
- RC Link lights blinking red and green.
- Gimbal status light on front is Green.
- App connects fine, shows picture but does not show update. Allows gimbal movement but no motor control.
- Tried the academy fix (press and hold on the hat symbol in the top right for 5 seconds to be presented with firmware downgrade screen), that says failed to find firmware.
- Go app does not show Firmware for aircraft and RC unit, says Version Not Available.
- Tried to downgrade to 1.7 but aircraft will not allow it.

Spoke to DJI support...surprised at how helpful they were. They get somewhat of a bad rap on here, but actually they were super helpful. We confirmed that the copter was at the latest FW 1.8 using the hidden log file in the MISC folder. Tried lots of different workarounds until we hit it...

You may have seen the C1, C2 reset procedure, I certainly had, unfortunately it seems its been somewhat adjusted with chinese forum whispers on here and the DJI Forum!

The procedure I used with guidance from DJI was as follows (ensure props are off):

1. Connect Phantom to PC, Power on and Format SD Card using the usual Windows Format (Right click on the drive, format, EX FAT)
2. Turn the phantom off.
3. Turn the RC controller on. Do not connect to your iPad/iPhone/Android just yet.
4. The important part: With the controller already on press and hold C1,C2 and the Shutter Button, turn the controller off whilst holding these buttons. Turn the controller back on whilst still holding them.
5. Plug Tablet/Phone back in and start DJI GO app.
6. Turn Phantom on
7. Connect to camera and click on status bar, my Firmware update was there waiting for me.
8. Update the firmware...


Hopefully this will work for others, it made a world of difference to me! It allowed the app to see the FW status of the RC Controller and Aircraft for the first time!

After the update was finished i was left with 1.6 on the RC and 1.8 on the Copter. RC SIGNAL LOSS HAS GONE!!!
 
  • Like
Reactions: Karanba
Joined
Sep 23, 2016
Messages
20
Reaction score
1
Age
52
it didn't work on my p3 pro 4k........I am having issues with my firmware and can not update. so I tried your method. 3x ....my pc doesn't not recognize the drone so I can't formate through the cord. It responds with its noise when you plug in a usb but no icon. my RC was not affected with your method either. I currently have a 1.6 on the rc and 1.1 on the copter.
 

Attachments

  • drone issue.png
    drone issue.png
    1.1 MB · Views: 677
Joined
Nov 15, 2016
Messages
6
Reaction score
1
Age
53
Has anyone tried this with a P3S? I'm completely new owner and very disgusted with DJI at this point.
 

New Threads

Members online

Forum statistics

Threads
141,316
Messages
1,454,802
Members
103,112
Latest member
DklawJonah