PH4 Charging Hub (Ultimaxx) Problems

Joined
Oct 30, 2016
Messages
217
Reaction score
113
Age
67
Location
Scottishland
Just added a Phantom 4 to the Squadron. It was what seemed a reasonable deal with the AC with 2 extra batteries and an Ultimaxx 3 Port Charging Hub thrown in.

The problem is that all I get are the 3 LED's blinking red (approx 1 second flash) regardless of charging set up:
* Plug in with no batteries.
* Plug in with 1 then 2 discharged batteries.
* Plug in with 1 charged battery.
* Plug in with 1 charged and 1 discharged battery
* Plug in with 2 charged batteries.

The notes on the base of the hub have LED Status descriptions for Flashing Green, Solid Green, Flashes Red, Solid Red and "Flashes Red at the same time" which indicates "Abnormal Input Power".

I can't see the DJI Charger putting out an Abnormal Charge.
Anyone else have one of these hubs and have it working as described?
The unit only has the DJI P4 Charger Connector and 17.5v Jack Plug. There are NO switches for setting Discharge Function or anything else as with the DJI Hub.

TBH, I don't see any real advantage to using these hubs as there is no real time saving when charging more than 1 battery. I get along fine with 5 P3 batteries and 2 chargers, one standard and the more powerful one for the P3 Pro.

Next is just me rambling on, skip it if you wish. :D
If things run as they have with my previous purchases then the P4 is about to be scrapped. I bought a P3/4k and it was withdrawn soon after. I bought a Refurb P3 Pro and the P3 Range was ditched the following day. Now that I have the P4, and things run to form, then it should be getting pulled any day soon. The P4 is actually marked as "Unavailable in Your Region" (UK) As it was, I purchased from Drones For Less which although looking like a UK website, it is actually sending stock from Brooklyn USA. To their credit, it only took 3 days to reach Glasgow, Scotland.... it took another 4 days for the courier to deliver to me, just outside Glasgow.
Minor glitch was only 1 extra battery instead of 2. It is being rectified hopefully in the standard 3 day slot. ;)
The Charge Hub issue is awaiting the words of the wise.
Goad! I can waffle on. :cool:
Cheers, and I would appreciate any Non-Abnormal Input from you chaps. :rolleyes:
 
Joined
May 28, 2017
Messages
8
Reaction score
6
Age
59
Just added a Phantom 4 to the Squadron. It was what seemed a reasonable deal with the AC with 2 extra batteries and an Ultimaxx 3 Port Charging Hub thrown in.

The problem is that all I get are the 3 LED's blinking red (approx 1 second flash) regardless of charging set up:
* Plug in with no batteries.
* Plug in with 1 then 2 discharged batteries.
* Plug in with 1 charged battery.
* Plug in with 1 charged and 1 discharged battery
* Plug in with 2 charged batteries.

The notes on the base of the hub have LED Status descriptions for Flashing Green, Solid Green, Flashes Red, Solid Red and "Flashes Red at the same time" which indicates "Abnormal Input Power".

I can't see the DJI Charger putting out an Abnormal Charge.
Anyone else have one of these hubs and have it working as described?
The unit only has the DJI P4 Charger Connector and 17.5v Jack Plug. There are NO switches for setting Discharge Function or anything else as with the DJI Hub.

TBH, I don't see any real advantage to using these hubs as there is no real time saving when charging more than 1 battery. I get along fine with 5 P3 batteries and 2 chargers, one standard and the more powerful one for the P3 Pro.

Next is just me rambling on, skip it if you wish. :D
If things run as they have with my previous purchases then the P4 is about to be scrapped. I bought a P3/4k and it was withdrawn soon after. I bought a Refurb P3 Pro and the P3 Range was ditched the following day. Now that I have the P4, and things run to form, then it should be getting pulled any day soon. The P4 is actually marked as "Unavailable in Your Region" (UK) As it was, I purchased from Drones For Less which although looking like a UK website, it is actually sending stock from Brooklyn USA. To their credit, it only took 3 days to reach Glasgow, Scotland.... it took another 4 days for the courier to deliver to me, just outside Glasgow.
Minor glitch was only 1 extra battery instead of 2. It is being rectified hopefully in the standard 3 day slot. ;)
The Charge Hub issue is awaiting the words of the wise.
Goad! I can waffle on. :cool:
Cheers, and I would appreciate any Non-Abnormal Input from you chaps. :rolleyes:
 
Joined
May 28, 2017
Messages
8
Reaction score
6
Age
59
I have the same 3 battery charging hub and it is doing the same thing yours is currently doing also, I just bought the item a month ago when it came as a package deal, frankly I think it's garbage/poor product. I'm scraping it and buying the original DJI hub. Sorry I couldn't give you a solution, but I have learned that when you encounter issues with these knock off brands to save a few bucks, it usually means more headaches, not that all knock off products are not good, but the ones that are I would not waste my time or effort.
 
Joined
Oct 30, 2016
Messages
217
Reaction score
113
Age
67
Location
Scottishland
Hi Flex, Like you it was part of a P4 Bundle. The Hub was a bonus part of the deal but the 2 extra batteries were the clincher. I have since contacted the distributor and they are sending out a replacement unit .. along with the 1 battery that was not delivered .. and I will just live with the 'wrong' backback that was sent. Boy! Did the manufacturer go nuts with the zips on this bag!! It opens out like a filleted Cod.

All in all, not the most satisfying online deal I have made. :imp::imp::grinning:
 
Joined
May 28, 2017
Messages
8
Reaction score
6
Age
59
I went through a company called The Pixel Hub, fortunately for me this was a good deal, the Ultimaxx Charging Hub was the only item that was faulty, everything else has worked flawlessly and the company was very reliable. I am also extremely happy and impressed with the performance of the P4P, wow what a fantastic piece of technology. I love this this drone, I have a few of them, but this one is the most advanced machines I have. :) BTW have you have any issues with your final video having a pulsating effect? When I view my videos of some forested scenery, I get a pulsating effect approximately every 3 seconds and it is frustrating to watch it that way. I have read some threads and it appears that it may be the resolution setting but IDK.
 
Joined
Oct 30, 2016
Messages
217
Reaction score
113
Age
67
Location
Scottishland
I have not had a chance to do anything with the P4 (standard) other than check and charge the batteries and drool over, ahem!, look at it sitting on the book-shelf. Weather does not often tie in at the week-ends and I depend on my cousin for transport. Thundered off last week. I have seen his new P4, also a standard, in action but not had any chance to check out his videos yet. He certainly hasn't mentioned any pulsating. Is this just affecting the new P4 range?

I have the P3/4k and P3Pro. These were intended as learning, backup units. We are intending going Pro this year (he passed his UK Certificate) and the P4's would probably be the main tools. It will depend on circumstances of the work and maybe the P3's will be called in. We shall see.

I ordered through Drones for Less, partly because of the price and it looked like a UK company with a London address. When I called them up about the missing battery, I got through to Brooklyn, NY and the delivery tracking was from the same NY.
I must say that it only took an impressive 3 days to get from NY to Glasgow ... then an unimpressive 5 days to get from the Glasgow Hub to my place (near Glasgow Airport) which was only 15 miles away. Figure!!

Hopefully I'll get the 'missing' battery delivered this week and get away for some flying & filming time, weather permitting. :sunglasses:
 
Joined
May 28, 2017
Messages
8
Reaction score
6
Age
59
I have not had a chance to do anything with the P4 (standard) other than check and charge the batteries and drool over, ahem!, look at it sitting on the book-shelf. Weather does not often tie in at the week-ends and I depend on my cousin for transport. Thundered off last week. I have seen his new P4, also a standard, in action but not had any chance to check out his videos yet. He certainly hasn't mentioned any pulsating. Is this just affecting the new P4 range?

I have the P3/4k and P3Pro. These were intended as learning, backup units. We are intending going Pro this year (he passed his UK Certificate) and the P4's would probably be the main tools. It will depend on circumstances of the work and maybe the P3's will be called in. We shall see.

I ordered through Drones for Less, partly because of the price and it looked like a UK company with a London address. When I called them up about the missing battery, I got through to Brooklyn, NY and the delivery tracking was from the same NY.
I must say that it only took an impressive 3 days to get from NY to Glasgow ... then an unimpressive 5 days to get from the Glasgow Hub to my place (near Glasgow Airport) which was only 15 miles away. Figure!!

Hopefully I'll get the 'missing' battery delivered this week and get away for some flying & filming time, weather permitting. :sunglasses:
Well good luck on your maiden flight with the P4, they are great machines, let me know how it all goes. Take care.
 
  • Like
Reactions: AuldGimpy
Joined
Jul 19, 2017
Messages
5
Reaction score
1
Age
60
Hi,
I also have the same charging hub. My problem is however slightly different. If the hub is powered without battery, all LEDs are cycling full green or flashing red. Current situation: nothing changes when I plug a fully charged battery in any slot. Previously when the batteries were not fully charged: only the first slot was able to turn the battery green LEDs on and charging it properly. All the other slots were useless.
Any solution to that?
 

New Threads

Forum statistics

Threads
137,879
Messages
1,424,598
Members
100,100
Latest member
Brend1993