P4P - Gimbal disconnected message, but goes away after several minutes

Joined
Oct 28, 2020
Messages
8
Reaction score
0
Age
36
Hello,

I have a Phantom 4 Pro that has an issue with the camera. The app will show no video and has a message stating the gimbal is disconnected. During this time, there is no pitch control from the remote. However, leaving it on its own for several minutes, the camera displays an image and I regain pitch control from the remote. If I turn the drone off, and back on, the same thing happens. No image for several minutes, then a picture is displayed.
 
Joined
Jan 29, 2021
Messages
31
Reaction score
20
Age
49
Have you opened up the drone and checked the gimbal flex cable connections?..... there is a very good chance that the flex cable is either a little loose or needs to be replaced. If it needs to be replaced, its not a fun repair but inexpensive and can be done in an hour or two. There are step by step videos for replacing this cable on Youtube.
 
Joined
Oct 28, 2020
Messages
8
Reaction score
0
Age
36
Have you opened up the drone and checked the gimbal flex cable connections?..... there is a very good chance that the flex cable is either a little loose or needs to be replaced. If it needs to be replaced, its not a fun repair but inexpensive and can be done in an hour or two. There are step by step videos for replacing this cable on Youtube.

I reseated the connections on the gimbal outside, but not inside.
 
Joined
Jan 29, 2021
Messages
31
Reaction score
20
Age
49
I reseated the connections on the gimbal outside, but not inside.
Inside would be more likely as it is almost like it is heating up and completing the connection..... with the outside inactive not much would be changing there.

I did a quick search and some folks with this problem have fixed it by using a different SD card..... seems unlikely but it worked for them
 

Capt KO

Capt KO
Joined
Feb 13, 2019
Messages
2,516
Reaction score
2,120
Age
69
Location
IRB, Fl
Connections that are corroded will often work that way. Takes a while for the connection to be made. Have you flown around salt water in the past? If so it's better to replace the cable while inside then try cleaning. Good luck
 

New Threads

Members online

No members online now.

Forum statistics

Threads
141,159
Messages
1,453,654
Members
102,984
Latest member
Demenslens