P3P not updating at all - always ends up with red light and long D... buzzer!

Joined
Apr 13, 2018
Messages
31
Reaction score
4
Age
35
Howdy!

Any ideas on fixing that?
Short description:
Having P3P with 4K camera and gimbal. Most probably issue starts in gimbal because before trying some updates there was "No image transmission signal" message on DJI Go App.
Have tried different ways formatting SD card, putting different firmware updates on it, nothing. Every time it starts "updating" when drone is turned on and ends with long DDddd.. buzzer sound (gimbal led turns solid red at that stage obviously).

Is it some sort of software issue or this sounds to be something technical (gimbal board / camera)?
I see here are a lot of educated users and repair guys, so maybe someone could assist me in a comment or DM? Would be pleased.
Cheers folks!
 
Joined
Apr 5, 2015
Messages
158
Reaction score
42
Age
60
Well first off, at least in my case and I suspect most cases, we became an "educated user" or "repair guy" simply because we have been down the road that you are travelling before. I will tell you that you have came to the right place for help.

You need to set your PC up to view hidden, or system files. If you're not sure how to do that, just Google it. There is a ton of information out there on how to do that. In fact, you may already be set up that way, but it's not the default setting in Windows.

Now, in your SD card that you used to do the update with, there will be a folder called MISC. Open that, and you will see a folder called LOG. Inside that folder, if your PC is set to view hidden and system files, you will see a file called P3P_FW_V01.11.0020 if you are using the latest version of firmware. Open that file with notepad, and copy and paste the result back to this forum. You are interested in the last few lines of the file. You will probably see one or more lines where it says DEVICE NOT DETECTED. It won't be helpful to speculate on what might be in there. We need to see what is there to be able to help.

Good luck!
 
Joined
Apr 13, 2018
Messages
31
Reaction score
4
Age
35
Well first off, at least in my case and I suspect most cases, we became an "educated user" or "repair guy" simply because we have been down the road that you are travelling before. I will tell you that you have came to the right place for help.

You need to set your PC up to view hidden, or system files. If you're not sure how to do that, just Google it. There is a ton of information out there on how to do that. In fact, you may already be set up that way, but it's not the default setting in Windows.

Now, in your SD card that you used to do the update with, there will be a folder called MISC. Open that, and you will see a folder called LOG. Inside that folder, if your PC is set to view hidden and system files, you will see a file called P3P_FW_V01.11.0020 if you are using the latest version of firmware. Open that file with notepad, and copy and paste the result back to this forum. You are interested in the last few lines of the file. You will probably see one or more lines where it says DEVICE NOT DETECTED. It won't be helpful to speculate on what might be in there. We need to see what is there to be able to help.

Good luck!
Thanks a lot for your kind assistance.
Really appreciated people are trying to help, I was surprised there are some hidden files on SD card but seeing something more than before makes me feel step forward already. :)
Will copy that .txt here in a moment.
Cheers
 
Joined
Apr 13, 2018
Messages
31
Reaction score
4
Age
35
Here is fresh log .txt file uploaded. Just formatted card once again, put newest firmware update and tried to update my P3P drone.
Hope this helps and hope I will learn something new again from your comments.
Looking forward.
Cheers
 

Attachments

Joined
Apr 5, 2015
Messages
158
Reaction score
42
Age
60
From what I have read, when you have device not detected at lines 0800, and 1500, those devices are the camera control board, and the camera itself. DJI support has always claimed that the only fix for that is to send it in for service. And in your most previous updates which are actually at the end of the file, that is what I see.

I did notice when I scrolled back to some previous version upgrades, there were a lot more lines with device not detected. The only time I've seen that, I actually had one of the camera cables not fully plugged in. I unmounted the camera, and checked the cable connections, and sure enough, one cable was not fully seated. I plugged the cable in, and was able to do the update, and everything worked fine.

That's about all I can tell you, check your cables, and try again. I know one thing for sure, whenever you get device not detected, that is why your update did not succeed. Maybe others can jump in and be of more assistance. Good luck.
 
Joined
Apr 13, 2018
Messages
31
Reaction score
4
Age
35
From what I have read, when you have device not detected at lines 0800, and 1500, those devices are the camera control board, and the camera itself. DJI support has always claimed that the only fix for that is to send it in for service. And in your most previous updates which are actually at the end of the file, that is what I see.

I did notice when I scrolled back to some previous version upgrades, there were a lot more lines with device not detected. The only time I've seen that, I actually had one of the camera cables not fully plugged in. I unmounted the camera, and checked the cable connections, and sure enough, one cable was not fully seated. I plugged the cable in, and was able to do the update, and everything worked fine.

That's about all I can tell you, check your cables, and try again. I know one thing for sure, whenever you get device not detected, that is why your update did not succeed. Maybe others can jump in and be of more assistance. Good luck.
Hi!
Thanks for your suggestions.
I will try to check as you said. Just wondering which contacts do you mean? Those which are connected on top board (to the drone motherboard) or those which are inside (flat film cables on top board)?

Since I want to learn servicing these kind of issues by my own (not involving DJI) I am looking forward to learn more things. Have done some basic repairs/replacements already but still want to go more deep into this.

Could you please advise how you are doing readings on those lines? Meaning, how do you know that lines 0800, and 1500 reflect camera connection? Is there any soft telling this or there is some manual with explanation of those line codes? I know @quaddamage is good at flashing and programming (as far as I have seen his posts), any more info on how I can learn these things to be able do some more repairs by myself?
Thanks in advance.
Cheers folks!
 

Oso

Premium Pilot
Joined
May 19, 2015
Messages
4,497
Reaction score
3,349
Location
Western US
We have all just learned these things by experience. No real manual per se. You have probably seen in your research that there are hundreds of posts pertaining to the No Image Transmission issue and Modules 8 and 15. In a vast majority of the cases it means an issue with the gimbal main board. Until recently, it meant finding an elusive replacement board. Now as you've mentioned there are more detailed repair (reflash) steps available thanks in large part to the work of @quaddamage .

Here is a table showing some of the module mappings.
 
Last edited:
  • Like
Reactions: quaddamage

New Threads

Forum statistics

Threads
137,480
Messages
1,420,848
Members
99,837
Latest member
mavicPRO2