Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Motor won't start. Red light LED indicator always turned on.

Discussion in 'Phantom FC40 Help' started by ezequielbduarte, Sep 6, 2014.

  1. ezequielbduarte

    Sep 6, 2014
    Likes Received:
    I bought a phantom fc40 last month. Everything was working perfectly fine, until I decided install a Gimbal. The process of installation worked just fine, but after i finished my work, I noticed that one motor didn't work. The indicator LED of that motor was always turned on.

    What's wrong? How can I fixed this problem? I've already tried everything and nothing seems to work.

    Here is a link of a video I made to show you the problem.

    https://www.youtube.com/watch?v=tcnaMx_ ... e=youtu.be

    Please help me, because I really love my phantom.
Similar Threads - Motor won't start Forum Date
Need help upgrading P3A!!! The drone motors won't start after upgrade Pro/Adv Discussion Saturday at 9:18 PM
Phantom 4 motors won't fully start Phantom 4 Help Jul 20, 2017
Standard Motors won't start up Phantom 3 Help Feb 27, 2017
My Phantom 2 vision + won't connect to my laptop. I am having trouble with starting the motors. Phantom 2 Vision + Help Sep 18, 2016
Motors won't start - remote controls camera instead Phantom 2 Vision Help Sep 9, 2016