Issue Connecting Phantom 4 Remote and USB device to Android tablet

Joined
Oct 31, 2023
Messages
7
Reaction score
0
Age
22
Hello everyone,
I'm experiencing some difficulties with my setup and would greatly appreciate any insights or solutions you might have. I'm attempting to connect my Phantom 4 remote controller to my Huawei Mediapad M5 tablet, along with an additional USB device.
Here's my setup:
Huawei Mediapad M5 tablet
Phantom 4 remote controller
USB-A to USB-A cable: https://www.amazon.de/dp/B089FBV4DQ?psc=1&ref=ppx_yo2ov_dt_b_product_details
OTG (On-The-Go) adapter: https://www.amazon.de/dp/B07NSQ56J9?psc=1&ref=ppx_yo2ov_dt_b_product_details

I connected the USB-A to USB-A cable from the Phantom 4 remote controller to a USB hub and then connected this USB hub to the OTG adapter. However, when I tried to use the DJI GO 4 App, it didn't recognize the remote controller. Interestingly, any other USB devices I connected to the tablet, such as a USB-Stick, mouse, or keyboard, were detected without any issues.
In an attempt to troubleshoot, I used my smartphone with a USB Type C port and a USB-C hub. I connected the Phantom 4 remote controller to the tablet using the USB-A to USB-A cable. Unfortunately, this configuration didn't work either, even though other USB devices connected to the hub were recognized.
I suspected that the issue might be with the USB-A to USB A-cable. To test this, I used a micro USB to USB-A adapter (Sony EC310) along with the USB-A to USB-A cable to connect the remote controller directly to the tablet. Surprisingly, this configuration worked in approximately only 1 out of 10 attempts.
Connecting the remote controller to the tablet using a standard smartphone data cable (USB-A to micro USB/USB-C) works perfectly fine. I'm aware that the micro USB connector has 5 pins, while the USB-A connector has only 4 pins, with certain applications requiring the connection of the 4th and 5th pins of the micro USB connector. Could the issue be related to the USB-A to USB-A cable I'm using?
Any help or suggestions would be greatly appreciated. Thank you in advance for your assistance!
Best regards,
Patrick
 
I think the problem is the hub. You should IMHO use a direct OTG cable from the RC to the tablet. I think you said you used a USB-A to USB-micro and it worked.
 
Yes, with a common USB-A to USB-micro cable it is working just fine, but I do need a second USB port on my tablet for another USB device, so I have to use an OTG adapter and a USB-Hub. Or I use a tablet/ smartphone with a USB-C port and a USB-C-Hub to connect the two USB devices (Phantom 4 remote and 5.8 GHz video receiver). But both options do not work with my current setup.
 
In my experience dji does not play well with others. My samsung is 3 outta 10. Hdmi module allows you to share Quad picture and data. What purpose does the "other" usb serve?
 
I am utilizing the Phantom 4 drone along with the FLIR VUE PRO 640 thermal imaging camera, positioned beneath the drone to safeguard fawns from potential harm during mowing operations. The thermal imaging operates independently from the drone, equipped with its own battery and a 5.8 GHz video transmitter. My goal is to develop an app using the DJI SDK, featuring a waypoint mission function similar to the Litchi App.

Currently, I receive thermal imaging through a 5.8 GHz receiver (https://www.amazon.de/gp/product/B081CVFSVR/ref=ppx_yo_dt_b_asin_title_o04_s00?ie=UTF8&psc=1) connected to the tablet. By combining the drone's GPS data with the thermal imaging, I can calculate the fawn's GPS position for later rescue.

The challenge, as mentioned in previous messages, is the inability to connect both the Phantom 4 and an additional USB device to the tablet. Would this work with the HDMI module?
 
The hdmi module seems to be what you need. It seems to double the info for screens and as such I believe it has the data your secondary usb needs.
 
I do not know exactly how you mean this. I need to connect two USB devices to my Tablet/ Smartphone (Phantom 4 and the 5.8 GHz receiver) but this does not work using a USB Hub. I first thought that the HDMI module does have a second USB port, where I can connect the 5.8 GHz receiver, but this is not the case.
 
Forget that last post. You need something like a separate monitor. The tablet probably can't handle two inputs that's why there is only one usb.
 
The 5.8 Ghz transmitter is completely independent of the Phantom 4 and just to transmit the thermal imaging. The transmitter is attached under the drone in a 3D printed case within the thermal camera and a battery. I want to get the thermal imaging to my smartphone/ tablet to calculate the individual heat points via a self programmed App. In order to get the thermal imaging to the smartphone, I do have a receiver, which I attached below. This receiver is connected to the smartphone/ tablet via micro USB, USB-C or USB-A. This setup work just fine. But the problem is, that I do need another micro USB or USB-C port to connect the Phantom 4 remote too, because both devices should work simultaneously with my App. As I mentioned above, a casual USB Hub does not work with the Phantom 4 remote. Furthermore there is no affordable tablet which does have more than one micro USB or USB-C port.

Receiver: Amazon.de

IMG_20230627_185616.jpg
 
Ok first off..Wow. Ok How about laptop running android. Or SBC. You obviously need something with more than one usb chip. That's about as much as I can help you. I'm no guiding light.
 
I tried an Android Emulator, but the DJI App did not work with the Laptop. I want the App and this setup to be easily accessible for everyone and every tablet, smartphone just with a USB Hub or something like that, but it seems to be, that I have to use a special tablet with more than one USB connection.
 
Hey everyone,

Apologies for the delay in responding. I recently got myself a Raspberry Pi 4 with 8 GB for this problem and installed Lineage 20.0. Here's a brief overview of my setup:
  • Powering the Raspberry Pi using the USB-C connector with the P4 remote controller.
  • Data transfer via the USB-C connector (USB-OTG).
  • Added a touch screen powered by a powered USB Hub and a Power bank.
However, I'm encountering an issue with the P4 remote controller connection. Sometimes, when I start the Raspberry Pi with the remote controller, it doesn't always recognize the connection with the DJI GO App. To resolve this, I've found that toggling USB debugging off and on in the Raspberry Pi settings (Android 13, Lineage 20.0) usually helps establish the connection.
The challenge here is that after a few restarts and toggling USB debugging off and on, the Raspberry Pi might not consistently recognize the remote controller, making it less reliable. I experimented with other operating systems from different providers, but they either couldn't recognize the drone or didn't perform as well as Lineage.

Has anyone else faced a similar issue or found a more reliable solution? Your insights would be greatly appreciated!

Thanks!
 

Recent Posts

Members online

No members online now.

Forum statistics

Threads
143,031
Messages
1,467,093
Members
104,900
Latest member
ROMzombi