iPhone 5 and Phantom 3

Joined
Nov 25, 2015
Messages
59
Reaction score
4
Age
39
Hi guys,

I know this thread has already been talked but it doesn't answer to my question.

So first, I want to buy a Phantom 3 Pro and I only have an iPhone 5 and an iPad mini 1.
I know DJI recommends minimum iPhone 5s and iPad mini 3.

So i've been looking for forum posts talking about my situation, and each time, i saw some guys with iPhone 5, unable to install the app.
I don't understand it. I'm on IOS 8 and 9, and I have no problem downloading and running the DJI go app. Sure i can't try it with the remote because I still don't have my Phantom but it seems to work.

So do you think i will be abble to operate my Phantom with my devices ?
Do you think i will still be covered by the warranty ?

Thank you

Xavier
 

msinger

Approved Vendor
Joined
Oct 30, 2014
Messages
30,956
Reaction score
10,255
Location
Harrisburg, PA (US)

RodPad

Premium Pilot
Joined
May 20, 2015
Messages
5,565
Reaction score
1,066
Age
56
Location
Pacific,NorthWet, 97031
Hi guys,

I know this thread has already been talked but it doesn't answer to my question.

So first, I want to buy a Phantom 3 Pro and I only have an iPhone 5 and an iPad mini 1.
I know DJI recommends minimum iPhone 5s and iPad mini 3.

So i've been looking for forum posts talking about my situation, and each time, i saw some guys with iPhone 5, unable to install the app.
I don't understand it. I'm on IOS 8 and 9, and I have no problem downloading and running the DJI go app. Sure i can't try it with the remote because I still don't have my Phantom but it seems to work.

So do you think i will be abble to operate my Phantom with my devices ?
Do you think i will still be covered by the warranty ?

Thank you

Xavier
If you can download the app DJI GO from the apple store it will work. What model of iPhone 5 to you have as far as I know the iPhone 5c will not work. The 5s will, FPV video might be poor.

Msinger, What I am missing?
 

msinger

Approved Vendor
Joined
Oct 30, 2014
Messages
30,956
Reaction score
10,255
Location
Harrisburg, PA (US)
Msinger, What I am missing?
If using an Apple device, the device must have at least an A7 processor. I'm using an iPad Mini 2 and it works well for me, so any other Apple device that has an A7 processor should be sufficient too. A device with a faster processor (A8 or A9) would make better sense though if that's an option.

tl;dr: Use a device on this list.
 
Joined
Nov 25, 2015
Messages
59
Reaction score
4
Age
39
I confirm that my phone is an iPhone 5. Not an iPhone 5c, or iPhone 5s.

@msinger so what ? The remote won't work at all or it will work but a bit laggy ? Why the DJI GO is running with my devices ? And the vendor of a big phantom reseller in my country told me it will work…
 

msinger

Approved Vendor
Joined
Oct 30, 2014
Messages
30,956
Reaction score
10,255
Location
Harrisburg, PA (US)
The remote won't work at all or it will work but a bit laggy ? Why the DJI GO is running with my devices ?
The Apple App store usually does not allow DJI GO to be installed on unsupported Apple devices. If you've managed to get it installed or you use iFunbox to install it, you'll likely see horrible performance. You don't need the DJI GO app to fly your Phantom, but I don't recommend flying without it -- since it offers a lot of vital flight information. All will not be lost if DJI GO crashes and/or locks up while you're flying though.

And the vendor of a big phantom reseller in my country told me it will work…
Some vendors will say anything to make a sale. Others are just misinformed. Either way, someone gave you bad information.
 
Joined
Nov 25, 2015
Messages
59
Reaction score
4
Age
39
I installed it by the app store… just normally, as whatever regular app. And on my both devices. No tweaks.
Weird, thanks a lot for the tips man.
 

RodPad

Premium Pilot
Joined
May 20, 2015
Messages
5,565
Reaction score
1,066
Age
56
Location
Pacific,NorthWet, 97031
What is the main diffs between I5, I5c and I5S, are their any other 5's?
 

LuvMyTJ

Admin
Staff Member
Premium Pilot
Joined
Feb 9, 2014
Messages
9,274
Reaction score
5,558
Location
Live! From New York!
The 5 was four gens ago, the 5S is three gens old, the 5C (c = cheap, jk) is the low end model 4 gens ago. So 5 & 5C came out at the same time, the following year the 5S came out. Each year the processor gets better. 6S is current till next September.
 
Joined
Nov 25, 2015
Messages
59
Reaction score
4
Age
39
5 and 5c is quite the same I think, but 5s got better processor and memory
 

RodPad

Premium Pilot
Joined
May 20, 2015
Messages
5,565
Reaction score
1,066
Age
56
Location
Pacific,NorthWet, 97031
The 5 was four gens ago, the 5S is three gens old, the 5C (c = cheap, jk) is the low end model 4 gens ago. So 5 & 5C came out at the same time, the following year the 5S came out. Each year the processor gets better. 6S is current till next September.
I think I get it do you have spread sheet this?
:)
 

RodPad

Premium Pilot
Joined
May 20, 2015
Messages
5,565
Reaction score
1,066
Age
56
Location
Pacific,NorthWet, 97031

RodPad

Premium Pilot
Joined
May 20, 2015
Messages
5,565
Reaction score
1,066
Age
56
Location
Pacific,NorthWet, 97031
So one thing I like to know. Between the P3s, P3a and P3p. If you can download the app, can you fly it with that mobile device and at LEAST have a usable FPV (You can tell if over a land or sea)?

So anybody got the best answer for xbiron?

 

RodPad

Premium Pilot
Joined
May 20, 2015
Messages
5,565
Reaction score
1,066
Age
56
Location
Pacific,NorthWet, 97031
Joined
Nov 23, 2015
Messages
18
Reaction score
2
Age
49
Hi guys,

I know this thread has already been talked but it doesn't answer to my question.

So first, I want to buy a Phantom 3 Pro and I only have an iPhone 5 and an iPad mini 1.
I know DJI recommends minimum iPhone 5s and iPad mini 3.

So i've been looking for forum posts talking about my situation, and each time, i saw some guys with iPhone 5, unable to install the app.
I don't understand it. I'm on IOS 8 and 9, and I have no problem downloading and running the DJI go app. Sure i can't try it with the remote because I still don't have my Phantom but it seems to work.

So do you think i will be abble to operate my Phantom with my devices ?
Do you think i will still be covered by the warranty ?

Thank you

Xavier
Hi, I was using the same setup (iPhone 5 with iOS 9.1 and p3pro) everything work normal except video lags a lot. Unviewable at certain distance. That y now I just bought iPad Air 2 for my p3. Hope it help you decide
 

RodPad

Premium Pilot
Joined
May 20, 2015
Messages
5,565
Reaction score
1,066
Age
56
Location
Pacific,NorthWet, 97031
I thank you, and i hope xbiron does to.
 
Joined
Nov 25, 2015
Messages
59
Reaction score
4
Age
39
I've bought an iPad mini 4, and I have sold my iPad mini 1. I can't wait to receive my phantom now ! Thanks santa…
 

New Threads

Forum statistics

Threads
135,466
Messages
1,401,587
Members
98,667
Latest member
Zelk12