Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Advanced Insignia Elite Tablet Help

Discussion in 'Phantom 3 Help' started by budzy, Nov 22, 2015.

  1. budzy

    Nov 20, 2015
    Likes Received:
    I am new to the fourm and bought a used phantom 3 advance in great shape. Here's my problem. I downloaded DJI GO onto my tablet running version 5.02. It starts out with the connect screen butter i do what it says it docent have the camera option to push to start. Some other information is i tried my iPhone and it works great (but of course too small). When i open the DJI GO app it comes up showing the inspire pro. And no where to change it till the next screen. I thought I read to enable usb debug so that is done also. The i download the DJI GO app it doesn't say what it is for but when I bring it up it says for phone. Are there wo different DJI GO apps? If there is I din't see one listed for tablets. Tried different cables. I read about others who have the insignia elite set up and feel I am just doing something stupid. I would like to get this solved so any help would be greatly appreciated and will try any suggestions. Thanks
    #1 budzy, Nov 22, 2015
    Last edited: Nov 22, 2015
  2. bobmyers

    May 10, 2015
    Likes Received:
    San Antonio, TX
    Have not heard of an Insignia Elite-- may not be compatible-- you will get some other input-- shortly from others.
    #2 bobmyers, Nov 22, 2015
    Last edited: Nov 22, 2015
Similar Threads - Insignia Elite Tablet Forum Date
Insignia flex elite review Pro/Adv Discussion Apr 24, 2016
Insignia Flex 8'' Tablet Review for P3A General Discussion Jul 5, 2016
Insignia tablet Phantom 2 Vision + Discussion Nov 26, 2015
Insignia General Discussion Mar 28, 2015
LNIB - P3P with Itelite DBS Mod & Drone World Nanuk 950 Case - Very Low Hours! Classifieds Today at 12:14 AM