imu weird errors

Joined
Dec 9, 2017
Messages
120
Reaction score
13
Age
29
hello pilots

im recently having a veeery strange issue with my p3 .. while awaiting initiation it never comletes.. it says in the main screen "sensor error" .. when i press it says "initiation failed" .. "accelerometer failed" .. "gyro error" .. thats so weird because..

- no crashes and always handcatching
- imu calibration is completing till 100%
- dji says "we dont know what is causin it"
- no shakes while initiating

so.. i dont know what to do..

any ideas to solve this riddle will be welcome..
xrider
 

Fly Dawg

"Electricity is really just organized lightning"
Premium Pilot
Joined
Apr 29, 2016
Messages
4,458
Reaction score
1,965
Location
Watkinsville, Georgia
- dji says "we dont know what is causin it"
Can it be assumed that you supplied DJI with then aircraft .dat log for analysis? If not, then I don't know how they can make that statement. We can take a look for you, if you have an aircraft .dat to supply.
 
Joined
Dec 9, 2017
Messages
120
Reaction score
13
Age
29
sorry for my late response..

here they are..




ive already given to dji some .dat files with this weird error.. they seem not understanding whats goin on.. so.. you are my only hope..

ps. ive looked into .txt and the 3 of them contain an "imu error numbers numbers numbers" .. googled that and it lead to nowhere.. i really dont know if its normal all this or if its something that i need to check.. i really need some help here..
 
Joined
Dec 9, 2017
Messages
120
Reaction score
13
Age
29
has anybody seen sth in the logs to determine the cause of this strange error??
 
Joined
Dec 9, 2017
Messages
120
Reaction score
13
Age
29
where are you??
you ve told me to give you .dat from the flights.. im still here and waiting for help.. 🙄
please?? anyone??
 

Fly Dawg

"Electricity is really just organized lightning"
Premium Pilot
Joined
Apr 29, 2016
Messages
4,458
Reaction score
1,965
Location
Watkinsville, Georgia
@xrider Sorry for the late response, been quite a busy weekend. Anyway, about all I can tell you is that the error does show up in the event stream. It certainly looks like there "may" be a hardware issue. The odd thing is that FLY412 and FLY414 show the error, but FLY415 does not. Below is from the event stream. Maybe @BudWalker could shed more light on the issue for you.

Gyro.PNG
 
Joined
Dec 9, 2017
Messages
120
Reaction score
13
Age
29
ookay.. if theres a hardware issue.. what could that be?? imu failure?? it calibrate normally.. it flies like a dream.. but when weather is humid or temp is droping.. thats when the error shows up.. and i really dont know if its the cause or if it is if its normal or not.. dji techs told me "everything its fine.. go fly" .. im a bit confused.. and feeling desparate.. really dont know if this is goin to happen mid flight.. or if it happens if its gonna crash or if its goin to auto recover.. its really complicated to me..
 

Fly Dawg

"Electricity is really just organized lightning"
Premium Pilot
Joined
Apr 29, 2016
Messages
4,458
Reaction score
1,965
Location
Watkinsville, Georgia
but when weather is humid or temp is droping.. thats when the error shows up..
That is not normal. From your description it sounds like a temperature issue related to the Gyro's and Accelerometers. If that is the case it will be basically impossible for you to locate yourself without the proper diagnostic equipment and a temperature chamber to locate the fault. Presumably, the IMU temp is fine during calibration, that would explain why it passes calibration.
 
Joined
Dec 9, 2017
Messages
120
Reaction score
13
Age
29
Presumably, the IMU temp is fine during calibration, that would explain why it passes calibration.
okay.. you ve got the .dat files.. from what you see.. is there a temp failure on imu??
i know that there is a heater inside there.. where exactly is it located?? on fc or into imu compartment??
do i have to change it or its just a non critical error that may lead to unknown??
i dont know whats goin on.. i dont know min and max working temps so i can understand if thats the case..
 

Fly Dawg

"Electricity is really just organized lightning"
Premium Pilot
Joined
Apr 29, 2016
Messages
4,458
Reaction score
1,965
Location
Watkinsville, Georgia
i dont know whats goin on.. i dont know min and max working temps so i can understand if thats the case..
A heater does not make sense for the IMU. It stabilizes it's own temp via fan. A heater would consume far too much power. This plot is from FLY412. Only the Z Gyro is responding it appears. This is something that IMO cannot be diagnosed via data alone. You will need to have this aircraft looked at by DJI. You are grasping at straws.

1569355924160.png
 
Joined
Dec 9, 2017
Messages
120
Reaction score
13
Age
29
weird things.. very weird things..
i went to dji with my little buddy 3 times to take a look about that thing.. whatever is causing it they ve told me "it needs nothing.. go fly" .. so i did.. till this thing came up again.. twice.. meh.. calibrated again.. went flying.. but.. the question "is that weird thing goin to happen midflight or is it showing up only during startup procedure so safety will not be affected at all??" remained unanswered.. only guesses.. me.. you.. dji.. mysteries of drones' life.. 🙄
 

Fly Dawg

"Electricity is really just organized lightning"
Premium Pilot
Joined
Apr 29, 2016
Messages
4,458
Reaction score
1,965
Location
Watkinsville, Georgia
ut.. the question "is that weird thing goin to happen midflight or is it showing up only during startup procedure so safety will not be affected at all??" r
If it is a temperature related issue, it is very possible mid flight. It is odd, I will agree with that. Intermittant issues and temp related are the hardest things to troubleshoot. It can be done with time and patience, but in this instance not worth the effort to attempt it. Just IMO..... Good Luck, and "maybe" it will not affect flight.👍 I would keep a close eye on it.
 

New Threads

Forum statistics

Threads
136,090
Messages
1,407,535
Members
99,034
Latest member
farjot