"IMU Still Initializing" message

Joined
Oct 26, 2019
Messages
21
Reaction score
15
Age
72
If you get this unexpected IMU message, try recalibrating the compass.

With a P3P I use regularly, after a move across town for another photo shoot, the motors wouldn't start and I got the message "IMU Still Initializing" in a yellow box. Never saw that before. No errors reported in the Aircraft Status drop-down window on the left side, and the message didn't go away even after a long wait. Rebooted the aircraft, no change. And the controller, still got same message.

Grasping at straws in an effort to get on with my day, I recalibrated the compass and Bingo - problem solved. I thought I'd post this since it just might save someone else a big hassle.
 

ianzone

**P4**
Joined
May 22, 2016
Messages
6,640
Reaction score
4,391
Age
51
Location
NZ
If you get this unexpected IMU message, try recalibrating the compass.

With a P3P I use regularly, after a move across town for another photo shoot, the motors wouldn't start and I got the message "IMU Still Initializing" in a yellow box. Never saw that before. No errors reported in the Aircraft Status drop-down window on the left side, and the message didn't go away even after a long wait. Rebooted the aircraft, no change. And the controller, still got same message.

Grasping at straws in an effort to get on with my day, I recalibrated the compass and Bingo - problem solved. I thought I'd post this since it just might save someone else a big hassle.
Can speed up imu aswell will a cold imu calibration,,even drone in fridge for 15 min to chill,,that way when you go to fly imu warm up is faster
 
Joined
Oct 13, 2020
Messages
3
Reaction score
5
Location
McCrae, Victoria, Australia
If you get this unexpected IMU message, try recalibrating the compass.

With a P3P I use regularly, after a move across town for another photo shoot, the motors wouldn't start and I got the message "IMU Still Initializing" in a yellow box. Never saw that before. No errors reported in the Aircraft Status drop-down window on the left side, and the message didn't go away even after a long wait. Rebooted the aircraft, no change. And the controller, still got same message.

Grasping at straws in an effort to get on with my day, I recalibrated the compass and Bingo - problem solved. I thought I'd post this since it just might save someone else a big hassle.
It has happened to me too, the message came up ‘IMU still initialising’ resulting in the drone props not turning. In exasperation I recalibrated the compass, and it flew.
 

New Threads

Members online

Forum statistics

Threads
139,522
Messages
1,439,380
Members
101,324
Latest member
Ed01