How do I get my Galaxy Tab S2 to connect?

Joined
Oct 3, 2015
Messages
42
Reaction score
0
Age
56
After a search I couldn't find a conclusive answer to this question. I put the tablet in Airplane Mode and I cannot get the remote to connect (How To Connect is all I get). I had been using an HTC One M8 and had to place it in USB Debugging Mode. I can't find that setting on the Tab S2 to try that, but I have read on here that that should not be neccessary. There was some mention of certain FW working and/or not working. Can anyone give me a step in the right direction, be it tablet settings or required FW? I am currently running 1.4.3. Thanks!
 
Joined
Oct 3, 2015
Messages
42
Reaction score
0
Age
56
After a search I couldn't find a conclusive answer to this question. I put the tablet in Airplane Mode and I cannot get the remote to connect (How To Connect is all I get). I had been using an HTC One M8 and had to place it in USB Debugging Mode. I can't find that setting on the Tab S2 to try that, but I have read on here that that should not be neccessary. There was some mention of certain FW working and/or not working. Can anyone give me a step in the right direction, be it tablet settings or required FW? I am currently running 1.4.3. Thanks!

I found out how to enter USB Debug Mode and all is well... :)
 

alokbhargava

Premium Pilot
Joined
Sep 28, 2015
Messages
6,943
Reaction score
2,325
Location
San Francisco, CA
...and Airplane mode has nothing to do with connection to RC.
 
Joined
Jan 15, 2016
Messages
698
Reaction score
128
Related to my other post I know but also revelant here.
Can you connect to the controller/P3 using wifi from a tablet or is it just via USB?
USB only; the P3S and P34K use wireless WiFi.
 
Joined
Dec 8, 2016
Messages
38
Reaction score
14
Age
77
I finally got my new Samsung S2 tablet connected to the DJI Go 4 app.
However, please be warned this does not connect every time and I will NOT fly my P4P with the S2 tablet until it gets officially Okayed by the DJI site. I'll keep using my Apple iPad Mini 4 which is rock solid. The S2's screen is brighter and sharper compared to the iPad.

1. Go into the SETTINGS of the S2.
2. Under DEVELOPER OPTIONS (near the bottom of the list), find USB CONFIGURATION.
3. Change it to RNDIS (USB Ethernet) from the standard setting of "Charging", or "MTP Protocol".

You will need to perform this function each and every time you want to connect to the DJI GO 4 app; at least that's been the case for me!

CAUTION: Half the time, the change to "RNDIS" will not stick, so keep checking if you still don't have a connection. It usually takes me 3 tries for the change to occur. Don't ask me why. Probably why DJI hasn't placed this tablet on its approved list.
 

New Threads

Members online

No members online now.

Forum statistics

Threads
141,958
Messages
1,459,555
Members
103,737
Latest member
Aristos