Gimbal issue

Joined
Jul 11, 2018
Messages
21
Reaction score
2
Age
27
Hello everyone!

can somebody help me what possible the issue of the gimbal of my phantom 3 standard? Some times it works perfectly but when i power up the drone it goes crazy sometimes and also when power up the drone it is not moving at all, i have live feed and no gimbal overload error on the screen. I’ve try the following trobleshoot but the problem still persist.

1. Calibrate the IMU and Gimbal
2. Tighten the hex screw at the Yaw arm
3. Align the shaft at the roll motor

 

Capt KO

Capt KO
Joined
Feb 13, 2019
Messages
2,380
Reaction score
2,006
Age
69
Location
IRB, Fl
I’ve seen YouTube videos with a similar, but worse, problem and it was the potentiometer in the gimble. Yours might be failing. You might try a search if you want to attempt the repair. Hope someone here has another easier solution. Good luck
 
Joined
Jul 11, 2018
Messages
21
Reaction score
2
Age
27
I’ve seen YouTube videos with a similar, but worse, problem and it was the potentiometer in the gimble. Yours might be failing. You might try a search if you want to attempt the repair. Hope someone here has another easier solution. Good luck

Hi! Thanks for the reply is that the potentiometer in the roll motor?
 

Capt KO

Capt KO
Joined
Feb 13, 2019
Messages
2,380
Reaction score
2,006
Age
69
Location
IRB, Fl
Hi! Thanks for the reply is that the potentiometer in the roll motor?
It’s in the big side plate, rounded top, flat bottom. Don’t have the link handy but check out YouTube video ‘shaky phantom 3 camera’ or google it. There’s good instruction on repairs for the problem.
 

New Threads

Forum statistics

Threads
140,515
Messages
1,448,435
Members
102,306
Latest member
ixf4414