FliFli AirDrop remote dropper

Joined
Feb 17, 2018
Messages
5
Reaction score
5
Age
42
Hi all, I feel I need to share this issue on this forum, as I have communicated with other owners of this popular remote release device who have had this issue and tried to resolve it with the manufacturer (without success) and have ended up throwing the whole lot in the trash in dismay.
I have owned the FliFli dropper for about six months and used it every weekend for drone fishing, it has been very effective and I have been very pleased with the 1km range and DJI user intuitive design.
However, a few weeks ago the remote would not complete the activation procedure, regardless of resetting or synchronising process being done.
I was then informed by another frustrated FliFli owner who experienced the same issue that if you keep the remote plugged in to a power source it operates fine, to my surprised this worked! I used the dropper for a couple of weeks coupled to a powerbank (believing that the Li-ion battery in the remote must be faulty or expired) without issue.
It was only once the powerbank accidentally became detached, that I discovered that the remote worked fine so long as the charging cable alone was attached! This suggests that perhaps the inductive load created by the cable is enough to keep the remote awake?????
Anyway, the battery holds fine and the system works well so long as the charging cable is attached to the remote!!
Hope this is helpful to other FliFli owners experiencing this annoying fault.
Cheers
 
Joined
Mar 28, 2019
Messages
13
Reaction score
13
I just ordered one, thanks for the info! I hope I don't experience the problems but if I do I have some clue as to what is going on:cool:
 
  • Like
Reactions: BigAl07
Joined
Feb 1, 2018
Messages
22
Reaction score
10
This message is just to Potential users of the P4 GANNET Bait Release of a problem which took me a while to work out, as to why the device would "Randomly" trigger 'release' without (deliberately) activating the 'trigger'.

The 'problem' is created by the trigger mechanism which is 'locked/released' upon to the 'On/Off' status of the 'front-right' underside 'landing light'.

(Landing lights ON = HoldLoad; OFF = 'ReleaseLoad')

The issue was that the load would drop when ANY flight or control 'event' also changed the On/Off status of the trigger (Landing Light) led, which is not actually random, but caused by...

  1. Recording Video (Light would go off ....and release load...)
  2. Taking a timed, or series of images, (light would flicker with each shot, and as the buffer filled, the blink got longer...) ..Drop!
  3. ..other??
The load wold drop shortly after activating video or image recording. Bugger!

Now I would guess that within the P4, Controller/app there are likely ways to disable the landing lights to get around this issue, but for me it was too late for the intended task.
 
Last edited:

New Threads

Forum statistics

Threads
134,081
Messages
1,387,766
Members
97,769
Latest member
BMiceli